<!DOCTYPE html>
<html lang="en">
    <head>
        
    
    <meta charset="utf-8"><link rel="dns-prefetch" href="https://securepubads.g.doubleclick.net/">
        <link rel="dns-prefetch" href="https://static.doubleclick.net/">
        <link rel="dns-prefetch" href="https://bidder.criteo.com/">
        <link rel="dns-prefetch" href="https://static.criteo.net/">
        <link rel="dns-prefetch" href="https://as-sec.casalemedia.com/">
        <link rel="dns-prefetch" href="https://js-sec.indexww.com/">
        <link rel="dns-prefetch" href="https://ib.adnxs.com/">
        <link rel="dns-prefetch" href="https://hbopenbid.pubmatic.com/">
        <link rel="dns-prefetch" href="https://fastlane.rubiconproject.com/">
        <link rel="dns-prefetch" href="https://mcclatchy-d.openx.net/">
        <link rel="dns-prefetch" href="https://mcclatchy-idahostatesman.zeustechnology.com/">
        <meta name="msapplication-TileColor" content="#FFFFFF"/>
        <meta name="msapplication-TileImage" content="https://www.idahostatesman.com/wps/source/images/idahostatesman/windowsmetro-144.png"/>
        <meta name="twitter:card" content="summary_large_image"/>
        <meta name="twitter:site" content="idahostatesman"/>
        <meta name="twitter:title" content="UPS driver dances with glee over treats left on doorstep in Mississippi, video shows"/>
        <meta property="og:site_name" content="idahostatesman"/>
        <meta property="og:type" content="article"/>
        <meta property="og:title" content="UPS driver dances with glee over treats left on doorstep in Mississippi, video shows"/>
        <meta property="og:url" content="https://www.idahostatesman.com/news/nation-world/national/article247839425.html"/>
        <meta property="og:description" content="The joyous moment was caught on camera."/>
        <meta name="twitter:description" content="The joyous moment was caught on camera."/>
        <meta property="og:image" content="https://cf-images.us-east-1.prod.boltdns.net/v1/static/5615998037001/6ab6372c-473b-4181-8682-71eac170c4cf/1c5bfed5-8446-44f9-b9b7-e08592d522fb/1280x720/match/image.jpg"/>
        <meta name="twitter:image" content="https://cf-images.us-east-1.prod.boltdns.net/v1/static/5615998037001/6ab6372c-473b-4181-8682-71eac170c4cf/1c5bfed5-8446-44f9-b9b7-e08592d522fb/1280x720/match/image.jpg"/>
        <meta property="fb:app_id" content="403238979787734"/>
        <meta name="title" content="UPS driver dances after finding snacks on doorstep in MS | Idaho Statesman"/>
        <meta name="allow-comments" content="true"/>
        <meta name="description" content="A Ring doorbell camera shows a UPS delivery driver dancing and jumping for joy over a bowl of snacks left on the doorstep of a Mississippi home."/>
        <meta name="keywords" content="UPS, delivery, snacks, Ring, Mississippi"/>
        <meta name="news_keywords" content="UPS, delivery, snacks, Ring, Mississippi"/>
        <meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1"/>
        <meta name="googlebot" content="noodp, noarchive"/>
        <meta name="viewport" content="width=device-width, initial-scale=1.0"/>
        <link rel="canonical" href="https://www.sunherald.com/news/nation-world/national/article247839425.html"/>
        <meta name="original-source" content="https://www.sunherald.com/news/nation-world/national/article247839425.html"/>
        <meta name="google-site-verification" content="WCAnzqvmOBLLCucDnFvnJsEdEimlIu_vDrFVjPt5c4Y"/>
        <link rel="amphtml" href="https://amp.idahostatesman.com/news/nation-world/national/article247839425.html">
    <meta name="apple-itunes-app" content="app-id=390819220, affiliate-data=at=1010lHsN&amp;ct=SmartAppBannerBOI, app-argument=https://www.idahostatesman.com/news/nation-world/national/article247839425.html?appNav=smartBanner">
    <meta property="article:opinion" content="false"/>
<meta name="msapplication-TileImage" content="/wps/build/images/idahostatesman/windowsmetro-144.png"/><meta property="fb:pages" content="43887022493" />
    <meta property="fb:pages" content="136604805589" />
    <meta property="fb:pages" content="119000034787001" />
    <meta property="fb:pages" content="150267368335431" />
    <meta property="fb:pages" content="122219744461968" />
    <title>UPS driver dances after finding snacks on doorstep in MS | Idaho Statesman</title>
<script>
  window.pageInfo = {
    'videoLead': 'true','access.tags': 'matbasic,matopend', 'enableConfiant': true,'accuweather.apiKey':'2ce96fe9da724185a27db1e6a3ecf580','accuweather.dev':'false','accuweather.locationKey':'328736','accuweather.locationKey1':'328735','accuweather.locationKey2':'350473','accuweather.locationKey3':'329451','accuweather.locationString':'Boise','accuweather.locationString1':'Twin Falls, ID','accuweather.locationString2':'Portland, OR','accuweather.locationString3':'Butte, MT','accuweather.partnerCode':'MCCLATCHY','adPlatform':'zeus aps ats adfree','amp.connatixPlayerId':'e3497c10-03b8-458e-b45b-e36e8e487d18','connatix.id':'3867257d-fab9-4e9e-b74c-1f61cde5d0ed','connatixPlayerId':'d63b1437-4108-466a-a9d9-e37584a22b4e','cs.circ_phone':'1-208-377-6370','cs.circ_url':'http://www.idahostatesman.com/myaccount','durationMedia':'1197','eea7bw':'0','enableYozonsPrebid':'true','facebook.app.id':'403238979787734','financialContent.account':'idahostatesman','findnsave.tracking':'findnsave','headerDateDisplay':'false','legacy.affiliateId':'1525','legacy.siteName':'idahostatesman','marketInfo.CarsAFF':'idstates','marketInfo.CarsSEO':'Search for used and new cars, trucks, SUVs and other vehicles on IdahoStatesman.com. Idaho Statesman also provides Treasure Valley, and Boise, ID with tools to help you buy your car such as comparison, how to negotiate with car dealers, auto loan calculators, financing tips and Blue Book values.','marketInfo.JobsQSCTY':'Boise','marketInfo.JobsQSSTS':'ID,US','marketInfo.JobsSEO':'Idaho Statesman and IdahoStatesman.com are proud to serve the people in Boise, Meridian, Nampa, Caldwell, Treasure Valley Idaho with a job search tool and career resource. You will find both full time and part time local opportunities in a variety of career fields including government, retail, medical, construction, restaurant and technology.','marketInfo.JobsSiteID':'ga_id003','marketInfo.Jobslr':'cbga_id','marketInfo.LiveConnectTag':'a-01e1','marketInfo.addcities':'Meridian, Eagle, Nampa, Garden City','marketInfo.adretargeting.kill_list':'[&quot;simpli.fi&quot;]','marketInfo.allow_ads':'true','marketInfo.allow_nativo':'true','marketInfo.careerbuilder.dmc_code':'boi','marketInfo.careerbuilder.dmc_id':'1216','marketInfo.careerbuilder.lr':'cbga_id','marketInfo.careerbuilder.mxjobsrchcriteria_rawwords':'outside+sales','marketInfo.careerbuilder.s_freshness':'30','marketInfo.careerbuilder.s_rawwords':'CustomField3:IDAHOTJ','marketInfo.clipped_taxonomy':'News/National','marketInfo.code':'BOI','marketInfo.county':'County','marketInfo.domain':'idahostatesman','marketInfo.followLinks':'true','marketInfo.kill_dealsaver':'true','marketInfo.location':'Boise','marketInfo.logoAltText':'Idaho Statesman','marketInfo.market_identifier':'BOI.site_idahostatesman','marketInfo.name':'Idaho Statesman','marketInfo.networkid':'7675','marketInfo.phone':'208-377-6200','marketInfo.product':'site','marketInfo.pushlyDomainKey':'XggquDAoKulzqKlMDAyXkuRr7mdzxq9ByKZf','marketInfo.region':'Treasure Valley','marketInfo.shortURL':'breaking','marketInfo.siteId':'36','marketInfo.sourcelevel':'national','marketInfo.state':'Idaho','marketInfo.state_abbreviation':'ID','marketInfo.staticDirectory':'idahostatesman','marketInfo.street_address':'1200 North Curtis Road, Boise, ID, 83706','marketInfo.taxonomy':'News/National///','marketInfo.webmaster_email':'onlinenews@idahostatesman.com','marketInfo.zipcode':'83706','nativo.story.placements':'831693,839821,844491','nativo.video.placements':'869336,869335','newsletter.name':'idahostatesman_breaking_newsletter','publication.domain':'IdahoStatesman.com','publication.mediadomain':'media.idahostatesman.com','suggestedContent':'{&quot;source&quot;:&quot;mgid&quot;, &quot;m&quot;:631416, &quot;tid&quot;:1035115, &quot;wid&quot;:996408}','wufoo.formID':'','marketInfo.pagelevel':'story','template': 'singlecolumnstory','vl': '1',
      'centennialZones': '5','sectionsIds': '40458','topicsTags': '','lotameId': '7451',
    'domainName': 'www.idahostatesman.com',
    'isNewPublicApi': 'true',
  'marketInfo.adsizes':{'outofpage':{},'wallpaper':{'1600x600':[1600,600],'None':[]},'floorboard':{'285x70':[285,70],'None':[]},'default':{'120x20':[120,20],'120x240':[120,240],'120x600':[120,600],'146x60':[146,60],'160x600':[160,600],'160x90':[160,90],'168x28':[168,28],'180x150':[180,150],'216x36':[216,36],'234x60':[234,60],'240x400':[240,400],'300x100':[300,100],'300x250':[300,250],'300x50':[300,50],'300x600':[300,600],'300x75':[300,75],'320x450':[320,450],'320x50':[320,50],'336x280':[336,280],'468x60':[468,60],'500x300':[500,300],'600x250':[600,250],'728x90':[728,90],'960x30':[960,30],'970x90':[970,90],'Billboard Flex':[[960,30],[970,90],[728,90],[970,250]],'Billboard Flex2':[[970,90],[970,250]],'Billboard Flex3':[[970,90],[970,250],[728,90]],'Flex Ad':[[300,250],[300,600]],'None':[],'Rising Star':[500,300],'Welcome Ad':[[300,250],[300,600],[550,480],[600,500]]}}};
  Object.freeze(window.pageInfo);
</script>
<script src='/static/yozons-lib/core.js'></script>
<script type="text/javascript">
    var mistats = mistats || {};
    mistats.pagelevel="Story";
    mistats.cmsid="Story:247839425";
    mistats.pagename="Story:247839425|UPS driver dances with glee over treats left on doorstep in Mississippi, video shows";
    mistats.taxonomy="News|National|||";
    mistats.channel="National";
    mistats.contentsource="Tanasia Kenney";
    mistats.pubdate="2020/12/14";
    mistats.moddate="2020/12/14 H15";
    mistats.keywords="UPS, delivery, snacks, Ring, Mississippi";
</script>
<script src="//media.idahostatesman.com/misites/ida/idahostatesman.js"></script>

  <script src='//assets.adobedtm.com/launch-ENe8f70e36bc2f473e93435c31a9a5ba80.min.js'></script>
    <!-- OneTrust Cookies Consent Notice start -->
    <script src="https://cdn.cookielaw.org/scripttemplates/otSDKStub.js" data-document-language="true" type="text/javascript" charset="UTF-8" data-domain-script="9fa609f8-8658-4f21-a075-8e39475e822f"></script>
      <script src="https://cdn.cookielaw.org/opt-out/otCCPAiab.js" type="text/javascript" charset="UTF-8" ccpa-opt-out-ids="C0004" ccpa-opt-out-geo="ca" ccpa-opt-out-lspa="true"></script>
      <script type="text/javascript">
          function OptanonWrapper() { }
      </script>
      <script>
        window.geofeed = function(options) {
          var state = options.state.toString();
          var linkDontSell = document.getElementById('onetrust-donotsell');
          if (state == 'CA') {
            linkDontSell.style = 'display: block;cursor: pointer;';
          } else {
            linkDontSell.style = 'display: none';
          }
        };
        // Call geo-location JSONP service
        var jsonp = document.createElement('script');
        jsonp.setAttribute('src', 'https://geolocation.onetrust.com/cookieconsentpub/v1/geo/location/geofeed');
        document.head.appendChild(jsonp);
      </script>
    <!-- OneTrust Cookies Consent Notice end -->
  

<script type="text/javascript" src="/wps/build/webpack/vendor.bundle-af2280e5bf1fac00e2b0.js"></script>
<script type="text/javascript" src="/wps/build/webpack/mi-header.bundle-15539dde6db92a4565c1.js"></script>

<script type="text/javascript">
        var getSubscribedFlag = checkUserSubscribed('MPPSessionId');
        if(getSubscribedFlag){
            renewSession();
        }
    </script>
<script>
        var dfpOnPageWrapEnabled = true;
    </script><script>
    var _prx = window._prx || [];
    _prx.push(['cfg.SetNoAutoStart']);
</script>
<script src="https://s.ntv.io/serve/load.js" async></script>


<link rel="apple-touch-icon" href="/wps/build/images/idahostatesman/touch-icon-iphone.png">
<link rel="apple-touch-icon" sizes="152x152" href="/wps/build/images/idahostatesman/touch-icon-ipad.png">
<link rel="apple-touch-icon" sizes="180x180" href="/wps/build/images/idahostatesman/touch-icon-iphone-retina.png">
<link rel="apple-touch-icon" sizes="167x167" href="/wps/build/images/idahostatesman/touch-icon-ipad-retina.png">
<link rel="shortcut icon" type="image/png" sizes="16x16" href="/wps/build/images/idahostatesman/favicon-16.png">
<link rel="shortcut icon" type="image/png" sizes="32x32" href="/wps/build/images/idahostatesman/favicon-32.png">
<link rel="shortcut icon" type="image/png" sizes="96x96" href="/wps/build/images/idahostatesman/favicon-96.png">
<link rel="shortcut icon" type="image/png" sizes="196x196" href="/wps/build/images/idahostatesman/favicon-196.png"><link href="https://fonts.googleapis.com/css?family=Noto+Sans:400,700|Noto+Serif:400,700&display=swap&subset=latin-ext" rel="stylesheet">
    <link href="/wps/build/webpack/css/mi-styles.fdb8222743ac99f22f8c.css" rel="stylesheet" type="text/css"/>



<script type="text/javascript" src="/wps/source/scripts/libs/guid.js"></script>
    <script>
    (function() {
        var identityCookieName = 'AccessToken'
         function generateIdentityCookie(IdentityModule) {
                var identityModule = new IdentityModule();
                var identityPrefix = 'mcv4';
                // core polyfill's promise before this script runs
                mi.loadAsync('https://api.ipify.org?format=json')
                .then(function(response) {
                    var json = JSON.parse(response);
                    identityModule.GenerateIdentity(identityCookieName, identityPrefix, [json.ip]);
                })
                .catch(function() {
                    identityModule.GenerateIdentity(identityCookieName, identityPrefix, [getGuid()]);
                });
        }
        var accessTokenCookie = mi.getCookie(identityCookieName);
        if (!accessTokenCookie) {
            mi.loadAsync('/wps/source/scripts/libs/identityModulev3.min.js').then(function(response) {
                var temp = {}
                // prevent identiyModule from being added to the window.
                new Function(response).call(temp);
                if (document.readyState === 'complete') {
                    generateIdentityCookie(temp.IdentityModule)
                } else {
                    window.addEventListener('load', function() {
                        generateIdentityCookie(temp.IdentityModule)
                    });
                }
            })
        }
    })();
    </script>












<script type="application/ld+json">
{
  "@context": "http://schema.org",
  "@type": "NewsArticle",

  "mainEntityOfPage": {
    "@type": "WebPage",
    "@id": "https://www.idahostatesman.com/news/nation-world/national/article247839425.html"
  },

  
  "headline": "UPS driver dances with glee over treats left on doorstep in Mississippi, video shows",
  "image": "https://cf-images.us-east-1.prod.boltdns.net/v1/static/5615998037001/6ab6372c-473b-4181-8682-71eac170c4cf/1c5bfed5-8446-44f9-b9b7-e08592d522fb/1280x720/match/image.jpg",
  "datePublished": "2020-12-14T03:52PM-07:00",
  "dateModified": "2020-12-14T03:52PM-07:00",
  "url": "https://www.idahostatesman.com/news/nation-world/national/article247839425.html",
  "isBasedOn": "https://www.sunherald.com/news/nation-world/national/article247839425.html",
  "thumbnailUrl": "https://cf-images.us-east-1.prod.boltdns.net/v1/static/5615998037001/6ab6372c-473b-4181-8682-71eac170c4cf/1c5bfed5-8446-44f9-b9b7-e08592d522fb/1280x720/match/image.jpg",
  "articleSection": "National",
  "creator": [],
  "keywords": ["UPS","delivery","snacks","Ring","Mississippi"],
  "author": [{"@type": "Person","name": "Tanasia Kenney"}],
  "publisher": {
     "name": "Idaho Statesman",
     "@type": "Organization",
     "logo": {
        "@type": "ImageObject",
        "url": "://www.idahostatesman.com/wps/build/images/idahostatesman/amp-logo.png"
     }
  },
  
  "isPartOf": {
    "@type": ["CreativeWork", "Product"],
    "name": "idahostatesman",
    "productID": "idahostatesman.com:AllBOI-5024"
  },
  
  "description": "A Ring doorbell camera shows a UPS delivery driver dancing and jumping for joy over a bowl of snacks left on the doorstep of a Mississippi home.",
  "isAccessibleForFree": "False",
  "hasPart":
    {
      "@type": "WebPageElement",
      "isAccessibleForFree": "False",
      "cssSelector" : ".paywalled"
    }
}
</script>


<meta name='parsely-metadata' content='{"article_id": "247839425"}'>

<script src="https://connect.facebook.net/en_US/sdk.js#xfbml=1&version=v3.2" async></script>

<script type="text/javascript">
  function callbackCaptcha(token) {
    const newsLetterForm = document.querySelector('#newsletter-signUpWidget');

    if (newsLetterForm) {
      const data = JSON.parse(newsLetterForm.getAttribute('data-json'));
      data.captchaToken = token;
      const $div = document.createElement('div');
      $div.classList.add('success');
      $div.innerHTML = "Thanks for subscribing; you should start to receive your newsletter shortly.";
      document.querySelector('.grecaptcha-badge').remove();
      newsLetterForm.innerHTML = '';
      newsLetterForm.appendChild($div);
    }
  }
</script>
<script src='https://www.google.com/recaptcha/api.js' async defer></script>


    </head>

    <body class="story wps-body-main  paywalled">
        
    
<!-- WPS upper navbar for subpubs -->


        
    
    <div class="upper-nav " id="tabbedNavigator" data-isImpact="" data-isInfluencers="" data-destinyPubName="">
        <div class="tab active">
            <a href="/" aria-label="Idaho Statesman"><img src="/wps/build/images/idahostatesman/logo.svg" alt="Idaho Statesman Logo"></a>
        </div>
        <div class="tab subpub ">
            <a id="secondTabLink" href="https://www.mcclatchydc.com/#originPub=idahostatesman" aria-label="mcclatchydc"><img id="secondTabImage" src="/wps/build/images/mcclatchydc/logo-impact.svg" alt="mcclatchydc Logo"></a>
        </div>
    </div>

<section id="flag" class="flag grid paper full-bleed standard" role="banner">
    <div id="zone-el-1" class="zone-el hidden"></div>
                <div class="flex icons" role="menu">
        <button id="sectionsmenu" class="flex" aria-haspopup="true" role="menuitem" >
            <svg viewBox="0 0 448 512"><path d="M16 132h416c8.837 0 16-7.163 16-16V76c0-8.837-7.163-16-16-16H16C7.163 60 0 67.163 0 76v40c0 8.837 7.163 16 16 16zm0 160h416c8.837 0 16-7.163 16-16v-40c0-8.837-7.163-16-16-16H16c-8.837 0-16 7.163-16 16v40c0 8.837 7.163 16 16 16zm0 160h416c8.837 0 16-7.163 16-16v-40c0-8.837-7.163-16-16-16H16c-8.837 0-16 7.163-16 16v40c0 8.837 7.163 16 16 16z"/></svg>
            <span class="h5 icon-label d-desktop">SECTIONS</span>
        </button><a href="#primary-content" class="flex tabkey-reveal" tabindex="1">
                <span class="button impact">Skip to Content</span>
            </a><a href="https://www.idahostatesman.com/e-edition/today" class="d-tablet" aria-label="eEdition" role="menuitem">
            <svg viewBox="0 0 576 512" aria-hidden="true"><path d="M552 64H112c-20.858 0-38.643 13.377-45.248 32H24c-13.255 0-24 10.745-24 24v272c0 30.928 25.072 56 56 56h496c13.255 0 24-10.745 24-24V88c0-13.255-10.745-24-24-24zM48 392V144h16v248c0 4.411-3.589 8-8 8s-8-3.589-8-8zm480 8H111.422c.374-2.614.578-5.283.578-8V112h416v288zM172 280h136c6.627 0 12-5.373 12-12v-96c0-6.627-5.373-12-12-12H172c-6.627 0-12 5.373-12 12v96c0 6.627 5.373 12 12 12zm28-80h80v40h-80v-40zm-40 140v-24c0-6.627 5.373-12 12-12h136c6.627 0 12 5.373 12 12v24c0 6.627-5.373 12-12 12H172c-6.627 0-12-5.373-12-12zm192 0v-24c0-6.627 5.373-12 12-12h104c6.627 0 12 5.373 12 12v24c0 6.627-5.373 12-12 12H364c-6.627 0-12-5.373-12-12zm0-144v-24c0-6.627 5.373-12 12-12h104c6.627 0 12 5.373 12 12v24c0 6.627-5.373 12-12 12H364c-6.627 0-12-5.373-12-12zm0 72v-24c0-6.627 5.373-12 12-12h104c6.627 0 12 5.373 12 12v24c0 6.627-5.373 12-12 12H364c-6.627 0-12-5.373-12-12z"/></svg>
        </a>
        <a href="/weather" class="d-tablet" aria-label="Weather" role="menuitem">
            <svg viewBox="0 0 640 512"><path d="M575.2 325.7c.2-1.9.8-3.7.8-5.6 0-35.3-28.7-64-64-64-12.6 0-24.2 3.8-34.1 10-17.6-38.8-56.5-66-101.9-66-61.8 0-112 50.1-112 112 0 3 .7 5.8.9 8.7-49.6 3.7-88.9 44.7-88.9 95.3 0 53 43 96 96 96h272c53 0 96-43 96-96 0-42.1-27.2-77.4-64.8-90.4zm-430.4-22.6c-43.7-43.7-43.7-114.7 0-158.3 43.7-43.7 114.7-43.7 158.4 0 9.7 9.7 16.9 20.9 22.3 32.7 9.8-3.7 20.1-6 30.7-7.5L386 81.1c4-11.9-7.3-23.1-19.2-19.2L279 91.2 237.5 8.4C232-2.8 216-2.8 210.4 8.4L169 91.2 81.1 61.9C69.3 58 58 69.3 61.9 81.1l29.3 87.8-82.8 41.5c-11.2 5.6-11.2 21.5 0 27.1l82.8 41.4-29.3 87.8c-4 11.9 7.3 23.1 19.2 19.2l76.1-25.3c6.1-12.4 14-23.7 23.6-33.5-13.1-5.4-25.4-13.4-36-24zm-4.8-79.2c0 40.8 29.3 74.8 67.9 82.3 8-4.7 16.3-8.8 25.2-11.7 5.4-44.3 31-82.5 67.4-105C287.3 160.4 258 140 224 140c-46.3 0-84 37.6-84 83.9z"/></svg>
        </a>
        <a href="#" id="search-icon" title="Search">
            <svg class="d-desktop" viewBox="0 0 512 512"><path d="M505 442.7L405.3 343c-4.5-4.5-10.6-7-17-7H372c27.6-35.3 44-79.7 44-128C416 93.1 322.9 0 208 0S0 93.1 0 208s93.1 208 208 208c48.3 0 92.7-16.4 128-44v16.3c0 6.4 2.5 12.5 7 17l99.7 99.7c9.4 9.4 24.6 9.4 33.9 0l28.3-28.3c9.4-9.4 9.4-24.6.1-34zM208 336c-70.7 0-128-57.2-128-128 0-70.7 57.2-128 128-128 70.7 0 128 57.2 128 128 0 70.7-57.2 128-128 128z"/></svg>
        </a>
        </div>

    <a href="https://www.idahostatesman.com" class="market-logo" aria-label="Idaho Statesman">
        <img src="/wps/build/images/idahostatesman/logo.svg" alt="Idaho Statesman Logo">
        <h1 class="title-meta">
            UPS driver dances with glee over treats left on doorstep in Mississippi, video shows | Idaho Statesman
        </h1>
    </a>
    <div id="signInOut" class="signin flex"></div>
    
    <script type="text/javascript">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</script>

    <div class="quick-nav d-tablet">
</div>

    <form tabindex="-1" action="/search/" class="site-search-id search paper searchbox" role="search">
    <input class="search-field" type="text" name="q" placeholder="Search" aria-label="Search Idaho Statesman" tabindex="0">
    <button class="impact" type="submit" aria-label="Search" tabindex="0">SUBMIT</button>
</form>
    </section>





<nav class="main-nav sans summary impact hidden" id="mainNav" role="menu" aria-hidden="true" tabindex="-1" >
    <button id="closenavigation" class="summary flex" tabindex="0" >
        <svg tabindex="-1" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 352 512"><path d="M242.72 256l100.07-100.07c12.28-12.28 12.28-32.19 0-44.48l-22.24-22.24c-12.28-12.28-32.19-12.28-44.48 0L176 189.28 75.93 89.21c-12.28-12.28-32.19-12.28-44.48 0L9.21 111.45c-12.28 12.28-12.28 32.19 0 44.48L109.28 256 9.21 356.07c-12.28 12.28-12.28 32.19 0 44.48l22.24 22.24c12.28 12.28 32.2 12.28 44.48 0L176 322.72l100.07 100.07c12.28 12.28 32.2 12.28 44.48 0l22.24-22.24c12.28-12.28 12.28-32.19 0-44.48L242.72 256z" fill="white"/></svg>
        <span class="h5 icon-label">SECTIONS</span>
    </button>

    <div class="search flex h-desktop" role="menuitem" onclick="this.classList.add('open')" tabindex="0">
            <svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 512 512"><path d="M505 442.7L405.3 343c-4.5-4.5-10.6-7-17-7H372c27.6-35.3 44-79.7 44-128C416 93.1 322.9 0 208 0S0 93.1 0 208s93.1 208 208 208c48.3 0 92.7-16.4 128-44v16.3c0 6.4 2.5 12.5 7 17l99.7 99.7c9.4 9.4 24.6 9.4 33.9 0l28.3-28.3c9.4-9.4 9.4-24.6.1-34zM208 336c-70.7 0-128-57.2-128-128 0-70.7 57.2-128 128-128 70.7 0 128 57.2 128 128 0 70.7-57.2 128-128 128z"/></svg>
            <span id="searchTitle" class="h5 icon-label soft">Search</span>
            <form tabindex="-1" action="/search/" class="site-search-id flex" role="search">
    <input type="text" name="q" placeholder="Search" aria-label="Search Idaho Statesman" tabindex="0">
    <button type="submit" aria-label="Search" tabindex="-1">
        <svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 448 512"><path d="M190.5 66.9l22.2-22.2c9.4-9.4 24.6-9.4 33.9 0L441 239c9.4 9.4 9.4 24.6 0 33.9L246.6 467.3c-9.4 9.4-24.6 9.4-33.9 0l-22.2-22.2c-9.5-9.5-9.3-25 .4-34.3L311.4 296H24c-13.3 0-24-10.7-24-24v-32c0-13.3 10.7-24 24-24h287.4L190.9 101.2c-9.8-9.3-10-24.8-.4-34.3z"/></svg>
    </button>
</form>

        </div>
    <a href="https://www.idahostatesman.com/e-edition/today" role="menuitem" tabindex="0">
            <svg title="e edition logo" version="1.1" viewBox="0 0 75 15" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><defs><polygon id="d" points="0 0.0057143 12.972 0.0057143 12.972 9.9949 0 9.9949"/><polygon id="c" points="0.12953 0.1404 10.854 0.1404 10.854 15 0.12953 15"/><polygon id="b" points="0.019662 0.050519 10.887 0.050519 10.887 10 0.019662 10"/><polygon id="a" points="0.22033 0.049333 11.626 0.049333 11.626 9.7338 0.22033 9.7338"/></defs><g fill="none" fill-rule="evenodd" opacity=".6"><g transform="translate(-42 -114)"><g transform="translate(42 114)"><g transform="translate(0 2)"><mask id="h" fill="white"><use xlink:href="#d"/></mask><path d="m7.6091 1.0178c0-0.38138-0.22131-0.57207-0.66393-0.57207-0.34048 0-0.68946 0.11001-1.047 0.33004-0.3575 0.22003-0.70649 0.50606-1.047 0.8581s-0.66393 0.73342-0.97036 1.1441c-0.30643 0.41071-0.56179 0.80676-0.76607 1.1881 0.068095 0.029337 0.18726 0.051339 0.3575 0.066008 0.17024 0.014668 0.30643 0.022003 0.40857 0.022003 0.98738 0 1.8556-0.3007 2.6046-0.9021 0.74905-0.6014 1.1236-1.3114 1.1236-2.1342m5.3625 3.4324c-0.57881 0.61607-1.2683 1.2541-2.0684 1.9142-0.80012 0.66008-1.6683 1.2615-2.6046 1.8042-0.93631 0.5442-1.9067 0.98278-2.9111 1.3202-1.0044 0.33737-2.0003 0.50606-2.9877 0.50606-1.6002 0-2.4004-0.61607-2.4004-1.8482 0-0.82143 0.24685-1.7089 0.74054-2.6623 0.49369-0.95198 1.1321-1.8335 1.9152-2.6403 0.7831-0.80676 1.6428-1.4815 2.5791-2.0242 0.93631-0.54273 1.8301-0.81409 2.6812-0.81409 0.47667 0 0.80863 0.073342 0.99589 0.22003 0.18726 0.14815 0.28089 0.33737 0.28089 0.57207 0 0.35204-0.12768 0.73342-0.38304 1.1441-0.25536 0.41218-0.63839 0.79943-1.1491 1.1661-0.51071 0.36671-1.1576 0.67474-1.9407 0.92411-0.7831 0.24936-1.7194 0.37404-2.8089 0.37404-0.17024 0.26403-0.3575 0.68208-0.56179 1.2541-0.20429 0.57207-0.30643 1.1515-0.30643 1.7382 0 1.2028 0.62988 1.8042 1.8896 1.8042 0.7831 0 1.5917-0.15989 2.4259-0.48406 0.83417-0.3227 1.6428-0.72608 2.4259-1.2101 0.7831-0.48406 1.5066-1.0121 2.1705-1.5842s1.2172-1.1075 1.6598-1.6062c0.068095-0.058673 0.1447-0.071875 0.22982-0.044005 0.085119 0.029337 0.12768 0.08801 0.12768 0.17602" fill="#fff" mask="url(#h)"/></g><path d="m23 15h-11v-1.2147h1.3472v-11.572h-1.3472v-1.2131h10.295v3.2506h-1.2832l-0.084629-0.80327c-0.10363-0.86204-0.29016-1.2343-2.361-1.2343h-2.9827v4.9159h2.1969c1.1174 0 1.304-0.19592 1.3454-0.82286l0.041451-0.54857h1.2832v3.9167h-1.2832l-0.041451-0.54857c-0.041451-0.62694-0.22798-0.82286-1.3454-0.82286h-2.1969v5.4824h3.5009c2.0501 0 2.3195-0.35102 2.4024-1.2914l0.10363-1.5282h1.4093v4.0343z" fill="#fff"/><g transform="translate(23)"><mask id="g" fill="white"><use xlink:href="#c"/></mask><path d="m7.9822 12.055v-4.7654c-0.80139-1.3569-1.7982-1.8803-2.8912-1.8803-2.0312 0-2.9498 1.6655-2.9498 4.3212 0 2.7898 1.1141 4.0094 2.8521 4.0094 1.0164 0 2.0507-0.44423 2.9889-1.6848zm-0.17592 1.4522c-0.91704 0.98862-1.9921 1.4926-3.2039 1.4926-2.4807 0-4.4728-1.9562-4.4728-5.2694 0-3.2356 1.8357-5.5812 4.6683-5.5812 1.3487 0 2.383 0.525 3.1844 1.6089v-4.4375h-1.3096v-1.1808h3.1844v13.427h0.99685v1.1421h-2.8717v-1.2018h-0.17592z" fill="#fff" mask="url(#g)"/></g><path d="m35.838 1.2344c0-0.68575 0.70884-1.2344 1.6483-1.2344s1.6504 0.5486 1.6504 1.2344c0 0.66616-0.71096 1.2131-1.6504 1.2131s-1.6483-0.54697-1.6483-1.2131zm-0.83792 13.766v-1.0972h1.295v-8.1262h-1.295v-1.1543h3.705v9.2805h1.295v1.0972h-5z" fill="#fff"/><path d="m41.882 12.106v-6.4334h-1.8824v-0.95703l0.64771-0.079888c1.0728-0.13695 1.6193-0.54617 1.7812-2.2467l0.14169-1.3891h1.2533v3.52h3.1761v1.1527h-3.1761v6.1595c0 1.3891 0.50602 1.8978 1.599 1.8978 0.54482 0 1.0508-0.13695 1.5771-0.31303v1.1918c-0.50602 0.25434-1.2937 0.39129-2.1034 0.39129-1.8824 0-3.0142-0.82171-3.0142-2.8939" fill="#fff"/><path d="m46.838 1.2344c0-0.68575 0.70884-1.2344 1.6483-1.2344s1.6504 0.5486 1.6504 1.2344c0 0.66616-0.71096 1.2131-1.6504 1.2131s-1.6483-0.54697-1.6483-1.2131zm-0.83792 13.766v-1.0972h1.295v-8.1262h-1.295v-1.1543h3.705v9.2805h1.295v1.0972h-5z" fill="#fff"/><g transform="translate(52 5)"><mask id="f" fill="white"><use xlink:href="#b"/></mask><path d="m2.1019 5.0253c0 2.5585 1.195 3.9096 3.3409 3.9096 2.1442 0 3.3409-1.3511 3.3409-3.9096 0-2.5763-1.1968-3.9096-3.3409-3.9096-2.1459 0-3.3409 1.3333-3.3409 3.9096m8.7848 0c0 2.9852-2.268 4.9748-5.4439 4.9748-3.1759 0-5.4232-1.9896-5.4232-4.9748 0-2.9852 2.2474-4.9748 5.4232-4.9748 3.1759 0 5.4439 1.9896 5.4439 4.9748" fill="#fff" mask="url(#f)"/></g><g transform="translate(63 5)"><mask id="e" fill="white"><use xlink:href="#a"/></mask><path d="m0.22033 9.7338v-0.99556h1.1044v-7.3733h-1.1044v-1.0474h3.1814v1.2074h0.12992c1.0611-0.81778 2.1853-1.4756 3.8743-1.4756 1.9489 0 3.1164 0.96 3.1164 2.7911v5.8978h1.1044v0.99556h-4.6105v-0.99556h1.4292v-5.24c0-1.4222-0.47639-2.08-1.8839-2.08-1.1675 0-2.142 0.42667-3.1597 1.1022v6.2178h1.4292v0.99556h-4.6105z" fill="#fff" mask="url(#e)"/></g></g></g></g></svg>
            <span class="transparent">Eedition</span>
        </a>
    
            <a href="/#navlink=subnav" tabindex="0" role="menuitem">Home</a>
        <div class="subsection" tabindex="-1" >
                <button class="summary  expander" tabindex="0"  aria-haspopup="true" aria-controls="menu-2"
                         id="menubtn-2" onclick="this.classList.toggle('open')" >
                    Customer Service
                </button>
                <div id="menu-2" role="menu" aria-labelledby="menubtn-2">
                    <div role="none"><a href="/customer-service/#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">Customer Service</a></div>
                    <div role="none"><a href="https://www.idahostatesman.com/mobile/#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">Mobile &amp; Apps</a></div>
                    <div role="none"><a href="/customer-service/contact-us/#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">Contact Us</a></div>
                    <div role="none"><a href="http://t.news.idahostatesman.com/webApp/mccSignupPage?siteName=idahostatesman#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">Newsletters</a></div>
                    <div role="none"><a href="https://k12nie.com/?p=idahostatesman#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">News in Education</a></div>
                    <div role="none"><a href="https://account.idahostatesman.com/static/subscribe/#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">Subscribe</a></div>
                    <div role="none"><a href="/customer-service/#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">Subscriber Services</a></div>
                    
                </div>
            </div>
        
            <hr class="nav-divider" role="separator" aria-hidden="true" tabindex="-1">
        
            <a href="/news/coronavirus/#navlink=subnav" tabindex="0" role="menuitem">Coronavirus</a>
        <div class="subsection" tabindex="-1" >
                <button class="summary  expander" tabindex="0"  aria-haspopup="true" aria-controls="menu-5"
                         id="menubtn-5" onclick="this.classList.toggle('open')" >
                    News
                </button>
                <div id="menu-5" role="menu" aria-labelledby="menubtn-5">
                    <div role="none"><a href="/news/#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">News</a></div>
                    <div role="none"><a href="https://www.idahostatesman.com/news/local/" role="menuitem" tabindex="0" role="menuitem">Local</a></div>
                    <div role="none"><a href="/news/local/community/boise#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">Boise</a></div>
                    <div role="none"><a href="/news/local/community/west-ada#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">West Ada</a></div>
                    <div role="none"><a href="/news/local/community/canyon-county#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">Canyon County</a></div>
                    <div role="none"><a href="/news/local/crime#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">Crime</a></div>
                    <div role="none"><a href="/news/northwest/idaho#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">Idaho News</a></div>
                    <div role="none"><a href="/noticias-en-espanol#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">Noticias en Español</a></div>
                    <div role="none"><a href="/news/nation-world/#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">Nation/World News</a></div>
                    <div role="none"><a href="/news/local/investigations/databases/#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">Databases</a></div>
                    <div role="none"><a href="/news/local/education/#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">Education</a></div>
                    <div role="none"><a href="/news/local/environment#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">Environment</a></div>
                    <div role="none"><a href="http://www.idahostatesman.com/news/local/military#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">Military News</a></div>
                    <div role="none"><a href="/news/weather/#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">Weather</a></div>
                    <div role="none"><a href="/news/local/traffic/#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">Traffic</a></div>
                    <div role="none"><a href="/news/local/news-columns-blogs/helping-works#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">Helping Works</a></div>
                    <div role="none"><a href="https://www.idahostatesman.com/news/local/investigations/#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">Investigations</a></div>
                    
                </div>
            </div>
        <div class="subsection" tabindex="-1" >
                <button class="summary  expander" tabindex="0"  aria-haspopup="true" aria-controls="menu-6"
                         id="menubtn-6" onclick="this.classList.toggle('open')" >
                    Sports
                </button>
                <div id="menu-6" role="menu" aria-labelledby="menubtn-6">
                    <div role="none"><a href="/sports/#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">Sports</a></div>
                    <div role="none"><a href="/sports/college/mountain-west/boise-state-university/boise-state-football#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">Boise State Football</a></div>
                    <div role="none"><a href="/sports/college/mountain-west/boise-state-university/boise-state-basketball#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">Boise State Basketball</a></div>
                    <div role="none"><a href="/sports/college/university-of-idaho#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">Idaho Vandals</a></div>
                    <div role="none"><a href="/sports/high-school/#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">High Schools</a></div>
                    <div role="none"><a href="/sports/chadd-cripe/#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">Chadd Cripe</a></div>
                    <div role="none"><a href="/sports/nfl/#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">NFL</a></div>
                    <div role="none"><a href="/sports/nba/#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">NBA</a></div>
                    <div role="none"><a href="/sports/nhl/#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">NHL</a></div>
                    <div role="none"><a href="/sports/mlb/#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">MLB</a></div>
                    <div role="none"><a href="/sports/golf/#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">Golf</a></div>
                    
                </div>
            </div>
        <div class="subsection" tabindex="-1" >
                <button class="summary  expander" tabindex="0"  aria-haspopup="true" aria-controls="menu-7"
                         id="menubtn-7" onclick="this.classList.toggle('open')" >
                    Politics
                </button>
                <div id="menu-7" role="menu" aria-labelledby="menubtn-7">
                    <div role="none"><a href="/news/politics-government/state-politics#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">Idaho Politics</a></div>
                    <div role="none"><a href="/news/politics-government/election#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">Elections</a></div>
                    <div role="none"><a href="/news/politics-government/politics-columns-blogs/politics-blog#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">Capitol &amp; State</a></div>
                    <div role="none"><a href="/news/local/news-columns-blogs/letters-from-the-west#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">Letters from the West</a></div>
                    <div role="none"><a href="/news/politics-government/#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">National Politics</a></div>
                    
                </div>
            </div>
        <div class="subsection" tabindex="-1" >
                <button class="summary  expander" tabindex="0"  aria-haspopup="true" aria-controls="menu-8"
                         id="menubtn-8" onclick="this.classList.toggle('open')" >
                    Business
                </button>
                <div id="menu-8" role="menu" aria-labelledby="menubtn-8">
                    <div role="none"><a href="/news/business/#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">Business</a></div>
                    <div role="none"><a href="/news/business/business-insider#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">Business Insider</a></div>
                    <div role="none"><a href="/news/business/biz-columns-blogs/#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">Business Columns &amp; Blogs</a></div>
                    <div role="none"><a href="/news/business/personal-finance/#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">Personal Finance</a></div>
                    <div role="none"><a href="http://www.legalnotice.org/pl/idahostatesman/landing1.aspx#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">Legal Notices</a></div>
                    
                </div>
            </div>
        <div class="subsection" tabindex="-1" >
                <button class="summary  expander" tabindex="0"  aria-haspopup="true" aria-controls="menu-9"
                         id="menubtn-9" onclick="this.classList.toggle('open')" >
                    Opinion
                </button>
                <div id="menu-9" role="menu" aria-labelledby="menubtn-9">
                    <div role="none"><a href="/opinion/#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">Opinion</a></div>
                    <div role="none"><a href="/opinion/editorials/#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">Editorials</a></div>
                    <div role="none"><a href="/opinion/editorial-cartoons#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">Editorial Cartoons</a></div>
                    <div role="none"><a href="/opinion/letters-to-the-editor/#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">Letters to the Editor</a></div>
                    <div role="none"><a href="/opinion/readers-opinion#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">Guest Opinion</a></div>
                    <div role="none"><a href="/opinion/letters-to-the-editor/submit-letter/#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">Submit a Letter or Opinion</a></div>
                    
                </div>
            </div>
        <div class="subsection" tabindex="-1" >
                <button class="summary  expander" tabindex="0"  aria-haspopup="true" aria-controls="menu-10"
                         id="menubtn-10" onclick="this.classList.toggle('open')" >
                    Entertainment
                </button>
                <div id="menu-10" role="menu" aria-labelledby="menubtn-10">
                    <div role="none"><a href="/entertainment/#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">Entertainment</a></div>
                    <div role="none"><a href="http://events.idahostatesman.com/#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">Events Calendar</a></div>
                    <div role="none"><a href="/entertainment/restaurants/restaurant-reviews/#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">Restaurant Reviews</a></div>
                    <div role="none"><a href="/entertainment/arts-culture/#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">Arts and Culture</a></div>
                    <div role="none"><a href="/entertainment/festival/#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">Festivals</a></div>
                    <div role="none"><a href="/entertainment/movies-news-reviews/#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">Movie Reviews</a></div>
                    <div role="none"><a href="http://events.idahostatesman.com/movies.aspx" role="menuitem" tabindex="0" role="menuitem">Movie Showtimes</a></div>
                    <div role="none"><a href="/entertainment/music-news-reviews/#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">Music</a></div>
                    <div role="none"><a href="/entertainment/tv/#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">Television</a></div>
                    <div role="none"><a href="/entertainment/books/#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">Books</a></div>
                    <div role="none"><a href="/entertainment/comics/#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">Comics</a></div>
                    <div role="none"><a href="http://games.idahostatesman.com/?arkpromo=site_subnav" role="menuitem" tabindex="0" role="menuitem">Puzzles &amp; Games</a></div>
                    <div role="none"><a href="/entertainment/horoscopes/#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">Horoscopes</a></div>
                    <div role="none"><a href="/entertainment/games-puzzles/#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">Puzzles</a></div>
                    
                </div>
            </div>
        <div class="subsection" tabindex="-1" >
                <button class="summary  expander" tabindex="0"  aria-haspopup="true" aria-controls="menu-11"
                         id="menubtn-11" onclick="this.classList.toggle('open')" >
                    Outdoors
                </button>
                <div id="menu-11" role="menu" aria-labelledby="menubtn-11">
                    <div role="none"><a href="/outdoors/#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">Outdoors</a></div>
                    <div role="none"><a href="/outdoors/playing-outdoors/#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">Playing Outdoors Blog</a></div>
                    <div role="none"><a href="/outdoors/biking#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">Biking</a></div>
                    <div role="none"><a href="/outdoors/camping#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">Camping</a></div>
                    <div role="none"><a href="/outdoors/fishing/#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">Fishing</a></div>
                    <div role="none"><a href="/outdoors/hiking#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">Hiking and Trails</a></div>
                    <div role="none"><a href="/outdoors/hunting/#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">Hunting</a></div>
                    <div role="none"><a href="/outdoors/recreation/#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">Winter Recreation</a></div>
                    
                </div>
            </div>
        <div class="subsection" tabindex="-1" >
                <button class="summary  expander" tabindex="0"  aria-haspopup="true" aria-controls="menu-12"
                         id="menubtn-12" onclick="this.classList.toggle('open')" >
                    Living
                </button>
                <div id="menu-12" role="menu" aria-labelledby="menubtn-12">
                    <div role="none"><a href="/living#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">Living</a></div>
                    <div role="none"><a href="/living/food-drink/#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">Food &amp; Drink</a></div>
                    <div role="none"><a href="/living/health-fitness/#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">Health &amp; Fitness</a></div>
                    <div role="none"><a href="/living/home-garden/#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">Home &amp; Garden</a></div>
                    <div role="none"><a href="/living/treasure#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">Treasure</a></div>
                    <div role="none"><a href="/living/pets/#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">Pets</a></div>
                    <div role="none"><a href="/living/religion/#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">Religion</a></div>
                    <div role="none"><a href="/living/travel/#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">Travel</a></div>
                    <div role="none"><a href="/living/living-here-guide/best-of-treasure-valley#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">Best of Treasure Valley</a></div>
                    <div role="none"><a href="/living/liv-columns-blogs/heart-of-treasure-valley#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">Heart of the Treasure Valley</a></div>
                    <div role="none"><a href="/living/home-garden/margaret-lauterbach/#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">Margaret Lauterbach</a></div>
                    <div role="none"><a href="/living/liv-columns-blogs/tim-woodward#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">Tim Woodward</a></div>
                    <div role="none"><a href="/living/liv-columns-blogs/advice-columns/#navlink=subnav" role="menuitem" tabindex="0" role="menuitem">Carolyn Hax</a></div>
                    
                </div>
            </div>
        
            <a href="/living/living-here-guide#navlink=subnav" tabindex="0" role="menuitem">Living Here</a>
        <div class="subsection" tabindex="-1" >
                <button class="summary  expander" tabindex="0"  aria-haspopup="true" aria-controls="menu-14"
                         id="menubtn-14" onclick="this.classList.toggle('open')" >
                    Obituaries
                </button>
                <div id="menu-14" role="menu" aria-labelledby="menubtn-14">
                    <div role="none"><a href="https://www.legacy.com/obituaries/idahostatesman/" role="menuitem" tabindex="0" role="menuitem">View Obituaries</a></div>
                    <div role="none"><a href="https://placead.mcclatchy.com/obits/boise/home/listItems.html" role="menuitem" tabindex="0" role="menuitem">Place an Obituary</a></div>
                    
                </div>
            </div>
        <div class="subsection" tabindex="-1" >
                <button class="summary  expander" tabindex="0"  aria-haspopup="true" aria-controls="menu-15"
                         id="menubtn-15" onclick="this.classList.toggle('open')" >
                    Video
                </button>
                <div id="menu-15" role="menu" aria-labelledby="menubtn-15">
                    <div role="none"><a href="https://www.idahostatesman.com/video" role="menuitem" tabindex="0" role="menuitem">All videos</a></div>
                    <div role="none"><a href="https://www.idahostatesman.com/news/video" role="menuitem" tabindex="0" role="menuitem">News Video</a></div>
                    <div role="none"><a href="https://www.idahostatesman.com/sports/video" role="menuitem" tabindex="0" role="menuitem">Sports Video</a></div>
                    <div role="none"><a href="https://www.idahostatesman.com/news/politics-government/state-politics/video" role="menuitem" tabindex="0" role="menuitem">State Politics Video</a></div>
                    <div role="none"><a href="https://www.idahostatesman.com/news/politics-government/video" role="menuitem" tabindex="0" role="menuitem">National Politics Video</a></div>
                    <div role="none"><a href="https://www.idahostatesman.com/news/business/video" role="menuitem" tabindex="0" role="menuitem">Business Video</a></div>
                    <div role="none"><a href="https://www.idahostatesman.com/entertainment/video" role="menuitem" tabindex="0" role="menuitem">Entertainment Video</a></div>
                    <div role="none"><a href="https://www.idahostatesman.com/outdoors/video" role="menuitem" tabindex="0" role="menuitem">Outdoors Video</a></div>
                    <div role="none"><a href="https://www.idahostatesman.com/living/video" role="menuitem" tabindex="0" role="menuitem">Living Video</a></div>
                    <div role="none"><a href="https://www.idahostatesman.com/living/living-here-guide/video" role="menuitem" tabindex="0" role="menuitem">Living Here Video</a></div>
                    
                </div>
            </div>
        
            <hr class="nav-divider" role="separator" aria-hidden="true" tabindex="-1">
        
            <a href="/customer-service/contests-promotions/#navlink=subnav" tabindex="0" role="menuitem">Contests</a>
        
            <a href="/advertise#navlink=subnav" tabindex="0" role="menuitem">Advertise</a>
        
            <a href="https://www.idahostatesman.com/classified-ads/#navlink=subnav" tabindex="0" role="menuitem">Classifieds</a>
        
            <a href="https://jobs.idahostatesman.com#navlink=subnav" tabindex="0" role="menuitem">Jobs</a>
        
            <a href="http://idahostatesman.adperfect.com/#navlink=subnav" tabindex="0" role="menuitem">Place An Ad</a>
        
            <hr class="nav-divider" role="separator" aria-hidden="true" tabindex="-1">
        
            <a href="https://www.idahostatesman.com/customer-service/about-us/#navlink=subnav" tabindex="0" role="menuitem">About Us</a>
        
            <a href="/mobile/#navlink=subnav" tabindex="0" role="menuitem">Mobile &amp; Apps</a>
        
            <a href="https://www.idahostatesman.com/archives/#navlink=subnav" tabindex="0" role="menuitem">Archives</a>
        
</nav>


        
    <div data-server-rendered="true"><div class="breaking-news-organism impact"></div> <div id="zone-el-2" class="zone-el"><div id="leaderboard-ad"><div class="mobile-leaderboard"></div></div></div> <article class="paper story-body"><!----> <header class="header"><h2 class="caps kicker-id h6">
    <a class="kicker" href="https://www.idahostatesman.com/news/nation-world/national">
      National
    </a>
  </h2>



  
    
  

  


  



  



  
  



  <h1 class="h1">
    
      
      UPS driver dances with glee over treats left on doorstep in Mississippi, video shows
    
  </h1>
  
   

  





  
  
    
    






    











<div class="bio">
        <div>
            <div>
                
                    
                                    
                            
                            
                            
                                
                            
                            
                            
                            
                            
                            
                                
                                
                                
                            
                            
                            
                            

    
        <p class="byline">
            <a href="mailto:tkenney@mcclatchy.com"> By Tanasia Kenney</a> 
            
        </p>
    


                    
                
            </div>
            <div>
                
    
        <time id="publish_date" class="publish-date">December 14, 2020 03:52 PM
        </time>
    
    

            </div>
     </div>

    
        

    
    

    
    
        
    
        
    
        
    
        
    
        
    
        
    
        
    
        
    
        
    
        
    
        
    
        
    
        
    
        
    
        
    
        
    
        
            
        
    
        
    
        
    
        
    
        
    
        
    
        
    
        
    
        
    
        
    
        
    
        
    
        
    
        
    
        
    
    
    
    
    
    
    
    

    
    


    <div class="social-network-macro">
        <ul class="share-list">
            <li class="share-icon">
                <a class="link-icon" title="Share on Twitter" aria-label="Share on Twitter" href="https://twitter.com/share?text=UPS+driver+dances+with+glee+over+treats+left+on+doorstep+in+Mississippi%2C+video+shows&amp;url=https://www.idahostatesman.com/news/nation-world/national/article247839425.html" onclick="window.open(this.href, '', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=400,width=600');return false;">
                    <span class="glyphicon glyphicon-twitter"></span>
                </a>
            </li>
            <li class="share-icon">
                
                    <a class="link-icon facebook-share" title="Share on Facebook" aria-label="Share on Facebook" href="https://www.facebook.com/sharer/sharer.php?u=https://www.idahostatesman.com/news/nation-world/national/article247839425.html" onclick="window.open(this.href, '', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=400,width=600');return false;">
                        <span class="glyphicon glyphicon-facebook"></span>
                    </a>
                
            </li>
            <li class="share-icon">
                <a class="link-icon" title="Share by Email" aria-label="Share by Email" href="mailto:?subject=UPS%20driver%20dances%20with%20glee%20over%20treats%20left%20on%20doorstep%20in%20Mississippi%2C%20video%20shows&body=https://www.idahostatesman.com/news/nation-world/national/article247839425.html">
                    <span class="glyphicon glyphicon-envelope"></span>
                </a>
            </li>
            <li class="share-icon extra-share-options-icon event-author-section" role="button">
                





    

    

    

    

    

    

    

    

    

    

    

    

    

    

    

    

    
        
    

    

    

    

    

    

    

    

    

    

    

    

    

    

    




<div class="extra-share-macro-container extra-share-author-section">
    <div class="extra-share-macro extra-share-macro-author-section">
        <div class="hover-row"></div>
        <div class="speech-bubble">
            <ul class="extra-share-options-list extra-share-options-container">
                <li class="extra-share-option">
                    <a title="Share on LinkedIn" aria-label="Share on LinkedIn" href="https://www.linkedin.com/shareArticle?mini=true&url=https://www.idahostatesman.com/news/nation-world/national/article247839425.html&title=UPS driver dances with glee over treats left on doorstep in Mississippi, video shows">
                        <span class="glyphicon glyphicon-linkedin"></span>
                    </a>
                </li>
                <li class="extra-share-option">
                    <a title="Share on Pinterest" aria-label="Share on Pinterest" href="https://www.pinterest.com/pin/create/button/?url=https://www.idahostatesman.com/news/nation-world/national/article247839425.html&description=UPS driver dances with glee over treats left on doorstep in Mississippi, video shows&media=https://cf-images.us-east-1.prod.boltdns.net/v1/static/5615998037001/6ab6372c-473b-4181-8682-71eac170c4cf/1c5bfed5-8446-44f9-b9b7-e08592d522fb/1280x720/match/image.jpg">
                        <span class="glyphicon glyphicon-pinterest"></span>
                    </a>
                </li>
                <li class="extra-share-option">
                    <a title="Share on Reddit" aria-label="Share on Reddit" href="https://www.reddit.com/submit?url=https://www.idahostatesman.com/news/nation-world/national/article247839425.html">
                        <span class="glyphicon glyphicon-reddit"></span>
                    </a>
                </li>
                <li class="extra-share-option">
                    <a title="Print" aria-label="Print" href="javascript:window.print();">
                        <span class="glyphicon glyphicon-print"></span>
                    </a>
                </li>
            </ul>            

            <div class="extra-share-options-container order-reprint-container">
                <a title="Reprints" aria-label="Reprints" href="https://www.mcclatchyreprints.com"> ORDER REPRINT
                    <span>&rarr;</span>
                </a>
            </div>
        </div>
    </div>
</div>

                <a class="link-icon" title="more" aria-label="more">
                    <span class="glyphicon glyphicon-share"></span>
                </a>
            </li>
        </ul>
    </div>

    
</div></header> <!----> <figure><div class="lead-item video">
        
            
                <div class="videoVueInstance new-video-design" is="brightcove-video-component" :player="player">
                    <div class="video">
                        <div id="video-detail-247843440-1607986396225" class="media-wrap ">
    <div id="playerWrap-247843440-1607986396225" class="video-media vjs-wrapper">    
        <video id="player-247843440-1607986396225"
            class="video-js vjs-16-9 mi-videojs 0"
            data-url="https://www.sunherald.com/news/nation-world/national/article247843440.html"
            data-title="Watch UPS driver jump for joy over snacks left on Mississippi doorstep"
            data-video-id="6216243786001"
            data-publication="sunherald"
            data-ad-tag="https://pubads.g.doubleclick.net/gampad/ads?ad_type=video&amp;client=ca-video-pub-3446305859157241&amp;env=vp&amp;gdfp_req=1&amp;unviewed_position_start=1&amp;output=vast&amp;sz=400x300&amp;url=[referrer_url]&amp;correlator=[timestamp]&amp;adsafe=high&amp;videoad_start_delay=0&amp;max_ad_duration=30000&amp;sdmax=120000&amp;vpa=1&amp;vpmute=1&amp;adtest=false&amp;ciu_szs=300x250&amp;iu=%2F7675%2FBOI.site_idahostatesman%2FNews%2FNational&amp;hl=en&amp;cmsid=2475939&amp;description_url=https%3A%2F%2Fwww.sunherald.com%2Fnews%2Fnation-world%2Fnational%2Farticle247843440.html&amp;vid_t=Watch%20UPS%20driver%20jump%20for%20joy%20over%20snacks%20left%20on%20Mississippi%20doorstep&amp;vid=6216243786001&amp;cust_params=sect%3DNational%26sec_sect%3D40458%26topic%3D%26vpa%3D1%26vpmute%3D1"
            data-account="5615998037001"
            data-key="BCpkADawqM3MUaKMdvVK9sePCrbXkwGMuQL4l-hCsaBJbpJ7c0J1oKpeux1Wb5Tyt2M2g3p_7g0S3zwPtBVRwx69jFtnmF7KSZeuFjJU2VWy6LFozYxUqSfU5xSbFM_0oDq7I760ld0YoOkh"
            data-cmsid="2475939"
                data-pub-account = "5615998029001"
                data-pub-key = "BCpkADawqM3xk0Y5oHDI2yNCA0sK9PttUOJCw01AQfm1MPJBrdgOtR0sCAZtfQjzb1pjxbD0gz6HHjH0l5V3y9J96d_19k7uEWJfQZxaPQO_WV4689dYgOycpDy23dcy-_iFUYMRlq2SrXcQ"
                data-pub-cmsid = "2476242"
            data-pre-ad-tag="https://pubads.g.doubleclick.net/gampad/ads?ad_type=video&amp;client=ca-video-pub-3446305859157241&amp;env=vp&amp;gdfp_req=1&amp;unviewed_position_start=1&amp;output=vast&amp;sz=400x300&amp;url=[referrer_url]&amp;correlator=[timestamp]&amp;adsafe=high&amp;videoad_start_delay=0&amp;max_ad_duration=30000&amp;sdmax=120000&amp;vpa=1&amp;vpmute=1&amp;adtest=false&amp;ciu_szs=300x250&amp;iu=%2F7675%2FBOI.site_idahostatesman%2FNews%2FNational&amp;hl=en"
                data-sec-tag = "40458"
                data-topic-tag = ""
            data-asset-type="video"
            data-video-auto-play="true"
            data-video-type="lead-asset"
            crossOrigin="anonymous"
            data-sport-article='false'
            data-is-new-video-design='false'
            playsinline
            data-video-iterator="0"
            data-enable-sticky="false"
            data-iris-killed="false">
            </video>
    </div>      
</div>

                    </div>
                </div>
            
        

        
            
                
            
        
    </div></figure> <script src="https://trinitymedia.ai/player/trinity/2900000552/?pageURL=https%3A%2F%2Fwww.idahostatesman.com%2Fnews%2Fnation-world%2Fnational%2Farticle247839425.html"></script> <div><!----></div> <!----> <!----> <!----> <p>A woman&#x2019;s kind gesture sent a UPS worker jumping for joy, online video shows.</p> <!----><p>Nashandra James&#x2019; doorbell camera <a href="https://www.facebook.com/100006239775339/videos/2753791531505479" target="_blank" rel="Follow">captured the driver&#x2019;s &#x201C;extra happy&#x201D; reaction</a> as she shimmied and danced with glee after finding a bowlful of snacks left at the doorstep of the home in Madison, Mississippi.</p> <!----><p>Donning a pair of red reindeer antlers, the driver went on her merry way after grabbing a bag of chips and some Pringles &#x2014; but not before turning to the camera to say &#x201C;thank you.&#x201D;</p> <!----><p>James, who just happened to be watching on the other side, said the moment was just as joyous for her.</p> <!----><p>&#x201C;Something to me said to &#x2018;just look.&#x2019; And so I looked,&#x201D; James told McClatchy News. &#x201C;For her to have that reaction, it just melted my heart because I know (drivers) are pulling really long hours, probably longer than before. Everyone ... is doing a lot of online shopping. So I greatly appreciate them, and I appreciate her.&#x201D;</p> <div class="zone grid combo"><div id="zone-el-101" class="zone-el"><form id="newsletter-signUpWidget" method="POST" class="inline-cta package"><h5 id="newsletter-title" class="h1">News alerts in your inbox</h5> <p id="newsletter-summary" class="summary">Sign up for email alerts and be the first to know when news breaks.</p> <input type="hidden" id="newsletterType" value="idahostatesman_breaking_newsletter"> <input id="s_email_address" name="s_email_address" value aria-label="Enter Email Address" placeholder="Enter Email Address" type="email"> <label for="g-recaptcha-response" class="hidden">Recaptcha</label> <div data-sitekey="6LcCJGUUAAAAADAmkD2iQN_k8a6FCpgo2VBei6su" data-callback="callbackCaptcha" data-size="invisible" data-badge="inline" class="g-recaptcha hidden"></div> <button class="button disabled">SIGN UP</button> <p class="small sans gray">This site is protected by reCAPTCHA and the Google <a href='https://policies.google.com/privacy'>Privacy Policy</a> and <a href='https://policies.google.com/terms'>Terms of Service</a> apply.</p></form> <script type="application/javascript">
  const newsLetterForm = document.querySelector('#newsletter-signUpWidget');
  const emailInput = newsLetterForm.querySelector('#s_email_address');
  const submitButton = newsLetterForm.querySelector('.button');
  const newsletterName = newsLetterForm.querySelector('#newsletterType').value;
  const newsletterData = {
    newsletterName,
  };

  function isEmailValid(email) {
    const re = /^(([^<>()[\]\\.,;:\s@"]+(\.[^<>()[\]\\.,;:\s@"]+)*)|(".+"))@((\[[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\])|(([a-zA-Z\-0-9]+\.)+[a-zA-Z]{2,}))$/;
    return re.test(email);
  };

  function showErrorMsg(node, msg) {
    const div = document.createElement('div');
    div.classList.add('errorText');
    div.classList.add('small');
    div.innerHTML = msg;
    if (node) {
      node.parentNode.insertBefore(div, node.nextSibling);
    }
  }

  function validateNewsletter() {
    const errorMsg = newsLetterForm.querySelector('.errorText');
    if (errorMsg) {
      errorMsg.remove();
    }
    if (emailInput.classList.contains('error')) {
      emailInput.classList.remove('error');
    }
    if (!isEmailValid(emailInput.value)) {
      showErrorMsg(emailInput, 'Please insert a valid email address!');
      emailInput.classList.add('error');
      submitButton.classList.add('disabled');
    } else {
      submitButton.classList.remove('disabled');
    }
  };

  function submitNewsletter(e) {
    e.preventDefault();
    validateNewsletter();
    if (submitButton.classList.contains('disabled')) {
      return false;
    }
    grecaptcha.execute();
    newsletterData.emailAddress = emailInput.value;
    newsLetterForm.setAttribute('data-json', JSON.stringify(newsletterData));
  }
    
  emailInput.addEventListener('change', function (e) {
    validateNewsletter();
  });

  newsLetterForm.addEventListener('submit', function (e) {
    submitNewsletter(e);
  });

  submitButton.addEventListener('click', function (e) {
    submitNewsletter(e);
  });
</script>
</div> <div id="zone-el-102" class="zone zone-el"></div></div><p>The woman walked away with an extra pep in her step, clicking her heels three times before climbing back into her truck.</p> <!----><p>James&#x2019; husband, Steven, posted about his wife&#x2019;s kind gesture on Facebook and said she&#x2019;s an avid shopper at holiday time.</p> <!----><p>&#x201C;She orders so much stuff during the holidays that she leaves snacks for all the drivers,&#x201D; Steven James wrote. &#x201C;Well today this UPS driver was extra happy to get her snack.&#x201D;</p> <!----><div class="embed-infographic"><div class="videowrapper"><div id="fb-root"></div><script async defer crossorigin="anonymous" src="https://connect.facebook.net/en_US/sdk.js#xfbml=1&amp;version=v9.0" nonce="XOUbZaAK"></script><div class="fb-post" data-href="https://www.facebook.com/steven.james.18062533/posts/3728639070561813" data-show-text="true" data-width><blockquote cite="https://www.facebook.com/steven.james.18062533/posts/3728639070561813" class="fb-xfbml-parse-ignore"><p>My wife has made a UPS drivers day today. She orders so much stuff during the holidays, that&#x2019;s she leaves snacks for all...</p>Posted by <a href="https://www.facebook.com/steven.james.18062533">Steven James</a> on&#xA0;<a href="https://www.facebook.com/steven.james.18062533/posts/3728639070561813">Saturday, December 12, 2020</a></blockquote></div></div></div> <!----><p>James said she&#x2019;s been doing this for about three years but only recently purchased a Ring doorbell camera to keep tabs on her deliveries. She said she hoped to spread a little cheer to local delivery drivers, especially during this busy holiday season.</p> <div class="zone grid combo"><div id="zone-el-103" class="zone-el"><div id="story-cta-widget" class="inline-cta package ad-widget"><h5 class="h1">All-access digital subscription</h5> <p class="summary">Connect to local news for just $1 a month for 3 months</p> <a href="https://account.idahostatesman.com/subscribe/create?param=f3JBDkc=&amp;offer=NmEfaxcUb3lSCUJAfRIiCEsoBgRFbyBADhZDG15QPgoUG0hQeHNFCkRHb29STx0HLisVS1BIbwE%2FcEtLAAxDdD1DeHpJGw8%3D&amp;cid=cta_onsite_.99mo-3mo-15.99_202011" class="button impact">VIEW OFFER</a></div> <script>
      document.addEventListener('DOMContentLoaded', function(){
        if (!getSubscribedFlag) {
          var ctaElement = document.querySelector('#story-cta-widget');
          ctaElement.parentElement.classList.remove('hidden')
          var newEvent = new CustomEvent('cta_widget', { detail: ctaElement });
          window.dispatchEvent(newEvent);
        }
      });
    </script></div> <div id="zone-el-104" class="zone zone-el"></div></div><p>&#x201C;I was doing most of my shopping online,&#x201D; she said. &#x201C;So it was just a way to say thank you because I was constantly getting packages ... coming to the house. &#x201C;I just wanted to show my appreciation. I never expected anyone to see the video.&#x201D;</p> <!----><p>James said it was her husband who encouraged her to post it online.</p> <!----><p>Each week, she leaves a bowl of snacks just outside the door with a note encouraging delivery drivers to help themselves, according to photos posted to her husband&#x2019;s Facebook page. She said she changes out the snacks frequently. </p> <!----><p>This week, it&#x2019;s bags of Hershey&#x2019;s Kisses, chocolate bars and other sweet treats.</p> <!----><p>&#x201C;I buy a lot of snacks for my child for school,&#x201D; James told McClatchy News. &#x201C;Anyone who comes to my house knows that I keep plenty of snacks, so it&#x2019;s just something that I continue to keep on hand.&#x201D;</p> <div id="zone-el-105" index="15" stnPlayerKill="false" allowStnPlayer="true" class="zone zone-el"></div><p>The video has garnered hundreds of reactions online. Many thanked James for her generosity and shared the joy felt by the UPS worker, <a href="https://www.instagram.com/p/CIuhmlInfOh/" target="_blank" rel="Follow">who has been identified</a> as Mimi Chandler.</p> <!----><p>Chandler and her daughter formerly starred on the <a href="https://www.mylifetime.com/shows/bring-it/season-1" target="_blank" rel="Follow">Lifetime reality show &#x201C;Bring It!,&#x201D;</a> which followed competitive majorette team The Dancing Dolls of Jackson.</p> <!----><p>&#x201C;As you can see I was excited about spotting the snack basket!&#x201D; Chandler wrote in an Instagram post.&#x201D; If you know me, you know I love snacks! (I used to take all the snacks while we were filming too)! I did a lil happy dance NOT thinking about the ring doorbell giggling at me!&#x201D;</p> <!----><p>McClatchy News reached out to Chandler for comment and is awaiting response.</p> <!----> <!----> <!----> <div></div> <div class="zone grid"><div class="related-stories story-module">
        <h5 class="caps">Related stories from  Idaho Statesman</h5>
        
        <div class="grid">
            
                
                    

<article class="package">
    
        


  



  




  <h2 class="caps kicker-id h6">
    <a class="kicker" href="/news/nation-world/national">
      national
    </a>
  </h2>



    

    


  


 
   



  
  



  <h3 >
    
      <a href="https://www.idahostatesman.com/news/nation-world/national/article247787490.html#storylink=related_inline" >
        
        Your mail carrier isn’t allowed to accept a cash tip. Here’s what you could do instead
      </a>
    
  </h3>
  
   

  
    <div class="time" >
      
        December 11, 2020 2:23 PM
      
    </div>
  




</article>


                
            
                
                    

<article class="package">
    
        


  



  




  <h2 class="caps kicker-id h6">
    <a class="kicker" href="/news/nation-world/national">
      national
    </a>
  </h2>



    

    


  


 
   



  
  



  <h3 >
    
      <a href="https://www.idahostatesman.com/news/nation-world/national/article247839435.html#storylink=related_inline" >
        
        Two-year-old abandoned at Goodwill with note and bag of clothes, Mississippi cops say
      </a>
    
  </h3>
  
   

  
    <div class="time" >
      
        December 14, 2020 1:56 PM
      
    </div>
  




</article>


                
            
                
                    

<article class="package">
    
        


  



  




  <h2 class="caps kicker-id h6">
    <a class="kicker" href="/news/business">
      business
    </a>
  </h2>



    

    


  


 
   



  
  



  <h3 >
    
      <a href="https://www.miamiherald.com/news/business/article247769405.html#storylink=related_inline" >
        
        Looking for extra holiday income? In South Florida, jobs are still available
      </a>
    
  </h3>
  
   

  
    <div class="time" >
      
        December 11, 2020 7:25 AM
      
    </div>
  




</article>


                
            
        </div>
        <hr>
    </div></div> <div class="figure"><div class="galleryVueInstance" is="gallery-container-component" :gallery="gallery">
  <span style="display: none" data-gallery-type="spillover-gallery" data-gallery-id="247842480" data-lang=""></span><div style="display: none"
      data-index="1"
      data-title=""
      data-src="https://www.sunherald.com/latest-news/8nruu1/picture247842480/alternates/FREE_1140/UPS%20worker.jpg"
      data-alt=""
      data-caption="A UPS worker in Mississippi danced with glee after finding a bowl of chips and other snacks on the doorstep of a home in Mississippi."
      data-photographer=""
      data-credit="Screenshot courtesy of Nashandra James">
    </div></div></div> <div class="story-module"><article> 
        
            
    
    

<div class="author-card package">
    <div class="thumb">
            <a href="/profile/241457261">
                <img class="author-thumb" src="https://www.sunherald.com/latest-news/kp7ofz/picture241758141/alternates/FREE_480/Tanasia%20Kenney" alt="Profile Image of Tanasia Kenney">
            </a>
    </div>

    

    
    <div class="flex">
        
            <h6 class="byline">
                <a href="/profile/241457261">Tanasia Kenney</a>
            </h6>
        
        <div class="social-media">
            
                
                
                <a href="https://twitter.com/Tanasia_Kenney">
                    <svg class="twitter" viewBox="0 0 512 512"><path d="M459.37 151.716c.325 4.548.325 9.097.325 13.645 0 138.72-105.583 298.558-298.558 298.558-59.452 0-114.68-17.219-161.137-47.106 8.447.974 16.568 1.299 25.34 1.299 49.055 0 94.213-16.568 130.274-44.832-46.132-.975-84.792-31.188-98.112-72.772 6.498.974 12.995 1.624 19.818 1.624 9.421 0 18.843-1.3 27.614-3.573-48.081-9.747-84.143-51.98-84.143-102.985v-1.299c13.969 7.797 30.214 12.67 47.431 13.319-28.264-18.843-46.781-51.005-46.781-87.391 0-19.492 5.197-37.36 14.294-52.954 51.655 63.675 129.3 105.258 216.365 109.807-1.624-7.797-2.599-15.918-2.599-24.04 0-57.828 46.782-104.934 104.934-104.934 30.213 0 57.502 12.67 76.67 33.137 23.715-4.548 46.456-13.32 66.599-25.34-7.798 24.366-24.366 44.833-46.132 57.827 21.117-2.273 41.584-8.122 60.426-16.243-14.292 20.791-32.161 39.308-52.628 54.253z"/></svg>
                </a>
                
                
                
                <a href="mailto:tkenney@mcclatchy.com">
                    <svg class="envelope" viewBox="0 0 512 512"><path d="M502.3 190.8c3.9-3.1 9.7-.2 9.7 4.7V400c0 26.5-21.5 48-48 48H48c-26.5 0-48-21.5-48-48V195.6c0-5 5.7-7.8 9.7-4.7 22.4 17.4 52.1 39.5 154.1 113.6 21.1 15.4 56.7 47.8 92.2 47.6 35.7.3 72-32.8 92.3-47.6 102-74.1 131.6-96.3 154-113.7zM256 320c23.2.4 56.6-29.2 73.4-41.4 132.7-96.3 142.8-104.7 173.4-128.7 5.8-4.5 9.2-11.5 9.2-18.9v-19c0-26.5-21.5-48-48-48H48C21.5 64 0 85.5 0 112v19c0 7.4 3.4 14.3 9.2 18.9 30.6 23.9 40.7 32.4 173.4 128.7 16.8 12.2 50.2 41.8 73.4 41.4z"/></svg>
                </a>
                
                
            
        </div>
    </div>
        <div class="summary package">
            <span>Tanasia is a national Real-Time reporter based in Atlanta covering Georgia, Mississippi and the southeastern U.S. She’s an alumna of Kennesaw State University and joined McClatchy in 2020.</span>
        </div>
</div>

        
    </article></div> <div id="zone-el-9" class="zone-el"><div></div></div> <div id="commenting-container" class="commenting-container element-spacing-large"><h6 class="h5">
    <a class="comments-toggle" href="javascript:void(0);">
        <span class="glyphicon glyphicon-comment-o"></span>&nbsp; Comments &nbsp;<span class="glyphicon glyphicon-chevron-down rotate"></span>
    </a>
</h6>

<!--Needs to be on the DOM on page load for IE. Needs to be visible to set the correct height of the comment component. I'm hiding it on document ready. Appending it later did not work-->

<!-- TEMPORARY CODE UNTIL API RELEASE THEIR TICKET -->

    <div id="fb-comments" class="fb-comments in" data-href="https://www.idahostatesman.com/news/nation-world/national/article247839425.html" data-width="100%" data-numposts="10"></div>


<!-- %%%%%%%%%%%%%%%%%%%%% -->

<!-- Correct CODE AFTER API RELEASES THEIR PROTOCOL CHANGE -->
        
<!-- %%%%%%%%%%%%%%%%%%%%% -->


<script>
    jQuery(document).ready(function () {
        mi.commentingFaceboook.init();
    });
</script></div></article> <section class="grid"><div id="zone-el-10" class="card read-next col-span-2 zone-el"><div class="label sticky">
    <h2 class="impact caps h5">
      Read Next
    </h2>
  </div>



    

    


    
        <figure>
            <a href="https://www.idahostatesman.com/news/business/article247828205.html#storylink=readnext" class="image-link-macro kfocusable" title="‘Healing is coming’: US health workers start getting vaccine">

                <img src="https://www.mcclatchy-wires.com/incoming/cn3fh7/picture247829945/alternates/LANDSCAPE_1140/APTOPIX_Virus_Outbreak_New_York_59043.jpg" alt="‘Healing is coming’: US health workers start getting vaccine">

                
                
            </a>
        </figure>
    

    
    <div class="package paper">
        <div class="header">
          


  



  




  <h2 class="caps kicker-id h6">
    <a class="kicker" href="https://www.idahostatesman.com/news/business/">
      Business
    </a>
  </h2>




          


  



  



  
  



  <h3 class="h1">
    
      <a href="https://www.idahostatesman.com/news/business/article247828205.html#storylink=readnext" >
        
        ‘Healing is coming’: US health workers start getting vaccine
      </a>
    
  </h3>
  
   

  





          
            
            
            
            
            
    






    











<div class="bio">
        <div>
            <div>
                
                    
                                    
                            
                            
                            
                            
                            
                            
                            
                            
                                
                                
                                
                            
                            
                            
                            

    
        <p class="byline">
            By LAURAN NEERGAARD  
            
                <span class="credit">AP Medical Writer</span> 
            
        </p>
    


                    
                
            </div>
            <div>
                
    
        <div id="publish_date-read-next" class="publish-date time">December 14, 2020 03:39 PM
        </div>
    
    

            </div>
     </div>

    
        

    
    

    
    
    
    
        
    
    
    
    
    
    

    
    


    <div class="social-network-macro">
        <ul class="share-list">
            <li class="share-icon">
                <a class="link-icon" title="Share on Twitter" aria-label="Share on Twitter" href="https://twitter.com/share?text=%E2%80%98Healing+is+coming%E2%80%99%3A+US+health+workers+start+getting+vaccine&amp;url=https://www.idahostatesman.com/news/business/article247828205.html" onclick="window.open(this.href, '', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=400,width=600');return false;">
                    <span class="glyphicon glyphicon-twitter"></span>
                </a>
            </li>
            <li class="share-icon">
                
                    <a class="link-icon facebook-share" title="Share on Facebook" aria-label="Share on Facebook" href="https://www.facebook.com/sharer/sharer.php?u=https://www.idahostatesman.com/news/business/article247828205.html" onclick="window.open(this.href, '', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=400,width=600');return false;">
                        <span class="glyphicon glyphicon-facebook"></span>
                    </a>
                
            </li>
            <li class="share-icon">
                <a class="link-icon" title="Share by Email" aria-label="Share by Email" href="mailto:?subject=%E2%80%98Healing%20is%20coming%E2%80%99%3A%20US%20health%20workers%20start%20getting%20vaccine&body=https://www.idahostatesman.com/news/business/article247828205.html">
                    <span class="glyphicon glyphicon-envelope"></span>
                </a>
            </li>
            <li class="share-icon extra-share-options-icon event-read-next-section" role="button">
                






    



<div class="extra-share-macro-container extra-share-read-next-section">
    <div class="extra-share-macro extra-share-macro-read-next-section">
        <div class="hover-row"></div>
        <div class="speech-bubble">
            <ul class="extra-share-options-list extra-share-options-container">
                <li class="extra-share-option">
                    <a title="Share on LinkedIn" aria-label="Share on LinkedIn" href="https://www.linkedin.com/shareArticle?mini=true&url=https://www.idahostatesman.com/news/business/article247828205.html&title=‘Healing is coming’: US health workers start getting vaccine">
                        <span class="glyphicon glyphicon-linkedin"></span>
                    </a>
                </li>
                <li class="extra-share-option">
                    <a title="Share on Pinterest" aria-label="Share on Pinterest" href="https://www.pinterest.com/pin/create/button/?url=https://www.idahostatesman.com/news/business/article247828205.html&description=‘Healing is coming’: US health workers start getting vaccine&media=https://www.idahostatesman.com/wps/build/images/undefined/facebook.jpg">
                        <span class="glyphicon glyphicon-pinterest"></span>
                    </a>
                </li>
                <li class="extra-share-option">
                    <a title="Share on Reddit" aria-label="Share on Reddit" href="https://www.reddit.com/submit?url=https://www.idahostatesman.com/news/business/article247828205.html">
                        <span class="glyphicon glyphicon-reddit"></span>
                    </a>
                </li>
                <li class="extra-share-option">
                    <a title="Print" aria-label="Print" href="javascript:window.print();">
                        <span class="glyphicon glyphicon-print"></span>
                    </a>
                </li>
            </ul>            

            <div class="extra-share-options-container order-reprint-container">
                <a title="Reprints" aria-label="Reprints" href="https://www.mcclatchyreprints.com"> ORDER REPRINT
                    <span>&rarr;</span>
                </a>
            </div>
        </div>
    </div>
</div>

                <a class="link-icon" title="more" aria-label="more">
                    <span class="glyphicon glyphicon-share"></span>
                </a>
            </li>
        </ul>
    </div>

    
</div>
            
           
          
        </div>

        
          <p class="summary">The largest vaccination campaign in U.S. history is underway with health workers getting the first shots on the same day the nation’s COVID-19 death toll hit a staggering 300,000.</p>
        

        
            
            
	<a href="https://www.idahostatesman.com/news/business/article247828205.html" class="more-link ">
		KEEP READING 
	</a>

        

    </div></div> <div id="zone-el-11" class="zone-el"><div id="trending-stories">
                
                
                

                

    
        
    
     
    
    
    
        
        
    
    

    
        
    

    
    
        
        <div class="paper">
        

            
                
                    
                    
                    
                        
                            
                        

                        

                        
                            
                        


                        
                        

                            
                            

                            

                            

                                
                                
                                


  






  <div class="label ">
    <h2 class="impact caps h5">
      Trending Stories
    </h2>
  </div>



                            
                        


                        
                            
                                
                            
                        


                        
                            

                                
                                
                                    <div class="package">
                                

                                


  



  



  
  



  <h3 >
    
      <a href="https://www.idahostatesman.com/opinion/from-the-opinion-editor/article247735425.html#storylink=trendingstories" >
        
        Americans sacrificed far more during World War II than we’re being asked today
      </a>
    
  </h3>
  
   

  
      <div class="update-date time" data-originalDate="1607971802"></div>
  





                                </div>
                                </article>
                            
                        
                    
                
                    
                    
                    
                        
                            
                        

                        

                        
                            
                        


                        
                        


                        
                            
                                
                            
                        


                        
                            

                                
                                
                                    <div class="package">
                                

                                


  



  



  
  



  <h3 >
    
      <a href="https://www.idahostatesman.com/sports/college/mountain-west/boise-state-university/boise-state-football/article247816090.html#storylink=trendingstories" >
        
        Boise State football will play for Mountain West title away from home, on network TV
      </a>
    
  </h3>
  
   

  
      <div class="update-date time" data-originalDate="1607908724"></div>
  





                                </div>
                                </article>
                            
                        
                    
                
                    
                    
                    
                        
                            
                        

                        

                        
                            
                        


                        
                        


                        
                            
                                
                            
                        


                        
                            

                                
                                
                                    <div class="package">
                                

                                


  



  



  
  



  <h3 >
    
      <a href="https://www.idahostatesman.com/news/business/article247801510.html#storylink=trendingstories" >
        
        The state says it overpaid your unemployment benefits. Now it demands the money back
      </a>
    
  </h3>
  
   

  
      <div class="update-date time" data-originalDate="1607976651"></div>
  





                                </div>
                                </article>
                            
                        
                    
                
                    
                    
                    
                        
                            
                        

                        

                        
                            
                        


                        
                        


                        
                            
                                
                            
                        


                        
                            

                                
                                
                                    <div class="package">
                                

                                


  



  



  
  



  <h3 >
    
      <a href="https://www.idahostatesman.com/sports/college/mountain-west/boise-state-university/boise-state-basketball/article247819200.html#storylink=trendingstories" >
        
        Official takes colossal punch to the face during Boise State’s win over Weber State
      </a>
    
  </h3>
  
   

  
      <div class="update-date time" data-originalDate="1607908323"></div>
  


  <div id="latest-news-nativo-slot" class="nativo-placeholder">
    <div></div>
  </div>




                                </div>
                                </article>
                            
                        
                    
                
                    
                    
                    
                        
                            
                        

                        

                        
                            
                        


                        
                        


                        
                            
                                
                            
                        


                        
                            

                                
                                
                                    <div class="package">
                                

                                


  



  



  
  



  <h3 >
    
      <a href="https://www.idahostatesman.com/news/local/community/west-ada/article247817520.html#storylink=trendingstories" >
        
        Two minors dead, one injured in early morning rollover crash near Star, police say
      </a>
    
  </h3>
  
   

  
    <div class="time" >
      
        December 13, 2020 12:21 PM
      
    </div>
  





                                </div>
                                </article>
                            
                        
                    
                
            
        
        </div>
        

    
    

            </div></div></section> <div id="zone-el-12" class="zone-el"><div><section id="subscription-cta-container">
            
    <div class="card horizontal swg-promo">
        <div class="promo package sans">
            <h5 class="title h1">All-access digital subscription</h5>
            <h6 class="h3">#ReadLocal</h6>
        </div>
        <div class="package">
            <p class="summary">Connect to local news for just $1 a month for 3 months</p>
            <a href="https://account.idahostatesman.com/subscribe/create?param=f3JBDkc=&amp;offer=NmEfaxcUb3lSCUJAfRIiCEsoBgRFbyBADhZDG15QPgoUG0hQeHNFCkRHb29STx0HLisVS1BIbwE%2FcEtLAAxDdD1DeHpJGw8%3D&amp;cid=cta_onsite_.99mo-3mo-15.99_202011" class="button impact">VIEW OFFER</a>
        </div>
    </div>

</section></div></div> <div id="zone-el-13" class="zone-el"><section><div class="grid"><article  id="secondary-story-2"  class="card "
                                    >

                                
                                

                                    


    
        <figure>
            <a href="https://www.idahostatesman.com/news/nation-world/national/article247843580.html#storylink=moresection" class="image-link-macro kfocusable" title="4.7-magnitude quake is latest in swarm of temblors to rattle Nevada area, USGS says">

                <img src="https://www.sacbee.com/latest-news/o8jj8b/picture247649410/alternates/LANDSCAPE_480/seisomete_fitted_fitted.jpg" alt="4.7-magnitude quake is latest in swarm of temblors to rattle Nevada area, USGS says">

                
                
            </a>
        </figure>
    

                                
                            

                            
                                
                                    
                                
                            

                            

                                
                                
                                    <div  class="package  "
                                        >
                                
                                


  



  




  <h2 class="caps kicker-id h6">
    <a class="kicker" href="https://www.idahostatesman.com/news/nation-world/national/">
      National
    </a>
  </h2>



                            
                        


                        
                            
                                
                            
                        


                        
                            

                                
                                

                                


  



  



  
  



  <h3 >
    
      <a href="https://www.idahostatesman.com/news/nation-world/national/article247843580.html#storylink=moresection" >
        
        4.7-magnitude quake is latest in swarm of temblors to rattle Nevada area, USGS says
      </a>
    
  </h3>
  
   

  
    <div class="time" >
      
        December 14, 2020 3:34 PM
      
    </div>
  





                                </div>
                                </article>
                            
                        
                    
                
            
        

    
    

    

    
  
    
      

      
        
      

      

      

    
        
    
     
    
    
    
        
    
    

    
        
    

    
    
        

            
                
                    
                    
                    
                        
                            
                        

                        

                        
                            
                        


                        
                        

                            
                            
                                
                                    
                                

                                

                                
                                    
                                        
                                    
                                

                                

                                <article  id="secondary-story-3"  class="card "
                                    >

                                
                                

                                    


    
        <figure>
            <a href="https://www.idahostatesman.com/news/nation-world/national/article247835810.html#storylink=moresection" class="image-link-macro kfocusable" title="Betting odds released for Cleveland MLB team’s new name. Here are the early favorites">

                <img src="https://www.star-telegram.com/latest-news/x6akk5/picture247840720/alternates/LANDSCAPE_480/AP20349098033603.jpg" alt="Betting odds released for Cleveland MLB team’s new name. Here are the early favorites">

                
                
            </a>
        </figure>
    

                                
                            

                            
                                
                                    
                                
                            

                            

                                
                                
                                    <div  class="package  "
                                        >
                                
                                


  



  




  <h2 class="caps kicker-id h6">
    <a class="kicker" href="https://www.idahostatesman.com/news/nation-world/national/">
      National
    </a>
  </h2>



                            
                        


                        
                            
                                
                            
                        


                        
                            

                                
                                

                                


  



  



  
  



  <h3 >
    
      <a href="https://www.idahostatesman.com/news/nation-world/national/article247835810.html#storylink=moresection" >
        
        Betting odds released for Cleveland MLB team’s new name. Here are the early favorites
      </a>
    
  </h3>
  
   

  
      <div class="update-date time" data-originalDate="1607983636"></div>
  





                                </div>
                                </article>
                            
                        
                    
                
            
        

    
    

    

    
  
    
      

      
        
      

      

      

    
        
    
     
    
    
    
        
    
    

    
        
    

    
    
        

            
                
                    
                    
                    
                        
                            
                        

                        

                        
                            
                        


                        
                        

                            
                            
                                
                                    
                                

                                

                                
                                    
                                        
                                    
                                

                                

                                <article  id="secondary-story-4"  class="card "
                                    >

                                
                                

                                    


    
        <figure>
            <a href="https://www.idahostatesman.com/news/nation-world/national/article247835365.html#storylink=moresection" class="image-link-macro kfocusable" title="Ever seen a bird help make tea? Idaho woman’s feathered friends go viral on TikTok">

                <img src="https://cf-images.us-east-1.prod.boltdns.net/v1/static/5615998029001/1b51a5f7-af47-4a54-bb16-9e4ae8f9cff6/d6e10b40-49c6-4478-8842-18c87485d435/1280x720/match/image.jpg" alt="Ever seen a bird help make tea? Idaho woman’s feathered friends go viral on TikTok">

                
                    <div class="icon-wrap">
                        <svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" width="38px" height="38px" viewBox="0 0 38 38" version="1.1">
                            <!-- Generator: Sketch 50.2 (55047) - http://www.bohemiancoding.com/sketch -->
                            <title>Video media</title>
                            <desc>Created with Sketch.</desc>
                            <defs/>
                            <g stroke="none" stroke-width="1" fill="none" fill-rule="evenodd">
                                <g fill="#FFFFFF">
                                    <path d="M19,38 C8.50658975,38 0,29.4934102 0,19 C0,8.50658975 8.50658975,0 19,0 C29.4934102,0 38,8.50658975 38,19 C38,29.4934102 29.4934102,38 19,38 Z M28.7384506,20.359375 C28.9128177,20.2589041 29,20.1391136 29,20 C29,19.8608864 28.9128177,19.7410959 28.7384506,19.640625 L13.6368159,11.0851818 C13.4624488,10.9847108 13.3127227,10.9731182 13.1876333,11.0504035 C13.0625438,11.1276889 13,11.2668004 13,11.4677422 L13,28.5322578 C13,28.7331996 13.0625438,28.8723111 13.1876333,28.9495965 C13.3127227,29.0268818 13.4624488,29.0152892 13.6368159,28.9148182 L28.7384506,20.359375 Z"/>
                                </g>
                            </g>
                        </svg>
                    </div>
                
                
            </a>
        </figure>
    

                                
                            

                            
                                
                                    
                                
                            

                            

                                
                                
                                    <div  class="package  "
                                        >
                                
                                


  



  




  <h2 class="caps kicker-id h6">
    <a class="kicker" href="https://www.idahostatesman.com/news/nation-world/national/">
      National
    </a>
  </h2>



                            
                        


                        
                            
                                
                            
                        


                        
                            

                                
                                

                                


  



  



  
  



  <h3 >
    
      <a href="https://www.idahostatesman.com/news/nation-world/national/article247835365.html#storylink=moresection" >
        
        Ever seen a bird help make tea? Idaho woman’s feathered friends go viral on TikTok
      </a>
    
  </h3>
  
   

  
      <div class="update-date time" data-originalDate="1607980665"></div>
  





                                </div>
                                </article>
                            
                        
                    
                
            
        

    
    

    

    
  
    
      

      
        
      

      

      

    
        
    
     
    
    
    
        
    
    

    
        
    

    
    
        

            
                
                    
                    
                    
                        
                            
                        

                        

                        
                            
                        


                        
                        

                            
                            
                                
                                    
                                

                                

                                
                                    
                                

                                

                                <article  id="secondary-story-5"  class="card "
                                    >

                                
                                

                                    


    
        <figure>
            <a href="https://www.idahostatesman.com/news/nation-world/article247840160.html#storylink=moresection" class="image-link-macro kfocusable" title="US COVID-19 deaths top 300,000 just as vaccinations begin">

                <img src="https://www.mcclatchy-wires.com/incoming/eqtl38/picture247840905/alternates/LANDSCAPE_480/Virus_Outbreak_300K_Deaths_30529.jpg" alt="US COVID-19 deaths top 300,000 just as vaccinations begin">

                
                
            </a>
        </figure>
    

                                
                            

                            
                                
                                    
                                
                            

                            

                                
                                
                                    <div  class="package  "
                                        >
                                
                                


  



  




  <h2 class="caps kicker-id h6">
    <a class="kicker" href="https://www.idahostatesman.com/news/nation-world/">
      Nation &amp; World
    </a>
  </h2>



                            
                        


                        
                            
                                
                            
                        


                        
                            

                                
                                

                                


  



  



  
  



  <h3 >
    
      <a href="https://www.idahostatesman.com/news/nation-world/article247840160.html#storylink=moresection" >
        
        US COVID-19 deaths top 300,000 just as vaccinations begin
      </a>
    
  </h3>
  
   

  
    <div class="time" >
      
        December 14, 2020 2:14 PM
      
    </div>
  





                                </div>
                                </article>
                            
                        
                    
                
            
        

    
    

    

    
  
    
      

      
        
      

      

      

    
        
    
     
    
    
    
        
    
    

    
        
    

    
    
        

            
                
                    
                    
                    
                        
                            
                        

                        

                        
                            
                        


                        
                        

                            
                            
                                
                                    
                                

                                

                                
                                    
                                

                                

                                <article  id="secondary-story-6"  class="card "
                                    >

                                
                                

                                    


    
        <figure>
            <a href="https://www.idahostatesman.com/news/nation-world/article247840275.html#storylink=moresection" class="image-link-macro kfocusable" title="Vaccine comes too late for the 300,000 US dead">

                <img src="https://cf-images.us-east-1.prod.boltdns.net/v1/static/5615998022001/527b0886-8c30-4c55-981a-5ddd422d2b60/fc30fcbd-9cc9-42a9-bd91-8dc47eba9927/1280x720/match/image.jpg" alt="Vaccine comes too late for the 300,000 US dead">

                
                
            </a>
        </figure>
    

                                
                            

                            
                                
                                    
                                
                            

                            

                                
                                
                                    <div  class="package  "
                                        >
                                
                                


  



  




  <h2 class="caps kicker-id h6">
    <a class="kicker" href="https://www.idahostatesman.com/news/nation-world/">
      Nation &amp; World
    </a>
  </h2>



                            
                        


                        
                            
                                
                            
                        


                        
                            

                                
                                

                                


  



  



  
  



  <h3 >
    
      <a href="https://www.idahostatesman.com/news/nation-world/article247840275.html#storylink=moresection" >
        
        Vaccine comes too late for the 300,000 US dead
      </a>
    
  </h3>
  
   

  
      <div class="update-date time" data-originalDate="1607980321"></div>
  





                                </div>
                                </article>
                            
                        
                    
                
            
        

    
    

    

    
  
    
      

      
        
      

      

      

    
        
    
     
    
    
    
        
    
    

    
        
    

    
    
        

            
                
                    
                    
                    
                        
                            
                        

                        

                        
                            
                        


                        
                        

                            
                            
                                
                                    
                                

                                

                                
                                    
                                        
                                    
                                

                                

                                <article  id="secondary-story-7"  class="card "
                                    >

                                
                                

                                    


    
        <figure>
            <a href="https://www.idahostatesman.com/news/nation-world/national/article247839435.html#storylink=moresection" class="image-link-macro kfocusable" title="Two-year-old abandoned at Goodwill with note and bag of clothes, Mississippi cops say">

                <img src="https://www.sunherald.com/latest-news/5wostm/picture247839735/alternates/LANDSCAPE_480/Screenshot%20(304).png" alt="Two-year-old abandoned at Goodwill with note and bag of clothes, Mississippi cops say">

                
                
            </a>
        </figure>
    

                                
                            

                            
                                
                                    
                                
                            

                            

                                
                                
                                    <div  class="package  "
                                        >
                                
                                


  



  




  <h2 class="caps kicker-id h6">
    <a class="kicker" href="https://www.idahostatesman.com/news/nation-world/national/">
      National
    </a>
  </h2>



                            
                        


                        
                            
                                
                            
                        


                        
                            

                                
                                

                                


  



  



  
  



  <h3 >
    
      <a href="https://www.idahostatesman.com/news/nation-world/national/article247839435.html#storylink=moresection" >
        
        Two-year-old abandoned at Goodwill with note and bag of clothes, Mississippi cops say
      </a>
    
  </h3>
  
   

  
    <div class="time" >
      
        December 14, 2020 1:56 PM
      
    </div>
  





                                </div>
                                </article></div></section></div> <!----> <div id="zone-el-99" class="zone-el"></div> <!----></div>

        
    



<footer class="impact">
  <section class="footer">
    <div class="package footer-connect">
        <h6 class="h3">Take Us With You</h6>
        <p class="summary">Real-time updates and all local stories you want right in the palm of your hand.</p>

        
            <div class="flex">
                <div class="icon">
                    
                        <img src="/wps/build/images/idahostatesman/favicon-32.png" alt="Icon for mobile apps" />
                    
                </div>

                
	<a href="https://idahostatesman.com/mobile" class="more-link icon-label h4">
		Idaho Statesman App 
	</a>

            </div>
        

        
            <div class="flex">
                <svg viewBox="0 0 512 512"><path d="M512 464c0 26.51-21.49 48-48 48H48c-26.51 0-48-21.49-48-48V200.724a48 48 0 0 1 18.387-37.776c24.913-19.529 45.501-35.365 164.2-121.511C199.412 29.17 232.797-.347 256 .003c23.198-.354 56.596 29.172 73.413 41.433 118.687 86.137 139.303 101.995 164.2 121.512A48 48 0 0 1 512 200.724V464zm-65.666-196.605c-2.563-3.728-7.7-4.595-11.339-1.907-22.845 16.873-55.462 40.705-105.582 77.079-16.825 12.266-50.21 41.781-73.413 41.43-23.211.344-56.559-29.143-73.413-41.43-50.114-36.37-82.734-60.204-105.582-77.079-3.639-2.688-8.776-1.821-11.339 1.907l-9.072 13.196a7.998 7.998 0 0 0 1.839 10.967c22.887 16.899 55.454 40.69 105.303 76.868 20.274 14.781 56.524 47.813 92.264 47.573 35.724.242 71.961-32.771 92.263-47.573 49.85-36.179 82.418-59.97 105.303-76.868a7.998 7.998 0 0 0 1.839-10.967l-9.071-13.196z"/></svg>

                
                
	<a href="http://t.news.idahostatesman.com/webApp/mccSignupPage?siteName=idahostatesman" class="more-link icon-label h4">
		View Newsletters  
	</a>

            </div>
        

        <div class="flex social">
            <a href="https://www.facebook.com/idahostatesman" aria-label="Facebook link">
                      <svg viewBox="0 0 264 512"><path d="M215.8 85H264V3.6C255.7 2.5 227.1 0 193.8 0 124.3 0 76.7 42.4 76.7 120.3V192H0v91h76.7v229h94V283h73.6l11.7-91h-85.3v-62.7c0-26.3 7.3-44.3 45.1-44.3z"/></svg>
                    </a>
                <a href="https://twitter.com/idahostatesman" aria-label="Twitter link">
                      <svg viewBox="0 0 512 512"><path d="M459.37 151.716c.325 4.548.325 9.097.325 13.645 0 138.72-105.583 298.558-298.558 298.558-59.452 0-114.68-17.219-161.137-47.106 8.447.974 16.568 1.299 25.34 1.299 49.055 0 94.213-16.568 130.274-44.832-46.132-.975-84.792-31.188-98.112-72.772 6.498.974 12.995 1.624 19.818 1.624 9.421 0 18.843-1.3 27.614-3.573-48.081-9.747-84.143-51.98-84.143-102.985v-1.299c13.969 7.797 30.214 12.67 47.431 13.319-28.264-18.843-46.781-51.005-46.781-87.391 0-19.492 5.197-37.36 14.294-52.954 51.655 63.675 129.3 105.258 216.365 109.807-1.624-7.797-2.599-15.918-2.599-24.04 0-57.828 46.782-104.934 104.934-104.934 30.213 0 57.502 12.67 76.67 33.137 23.715-4.548 46.456-13.32 66.599-25.34-7.798 24.366-24.366 44.833-46.132 57.827 21.117-2.273 41.584-8.122 60.426-16.243-14.292 20.791-32.161 39.308-52.628 54.253z"/></svg>
                    </a>
                <a href="http://www.youtube.com/user/idahostatesman" aria-label="Youtube link">
                      <svg viewBox="0 0 576 512"><path d="M549.655 124.083c-6.281-23.65-24.787-42.276-48.284-48.597C458.781 64 288 64 288 64S117.22 64 74.629 75.486c-23.497 6.322-42.003 24.947-48.284 48.597-11.412 42.867-11.412 132.305-11.412 132.305s0 89.438 11.412 132.305c6.281 23.65 24.787 41.5 48.284 47.821C117.22 448 288 448 288 448s170.78 0 213.371-11.486c23.497-6.321 42.003-24.171 48.284-47.821 11.412-42.867 11.412-132.305 11.412-132.305s0-89.438-11.412-132.305zm-317.51 213.508V175.185l142.739 81.205-142.739 81.201z"/></svg>
                    </a>
                </div>
    </div>

    <div class="footer-links">
    <div class="package">
            <h6 class="h5 caps">Subscriptions</h6>
            <a href="https://account.idahostatesman.com/static/subscribe/#navlink=mi_footer">Start a Subscription</a>
            <a href="https://www.idahostatesman.com/customer-service">Customer Service</a>
            <a href="https://www.idahostatesman.com/e-edition/today#navlink=mi_footer">eEdition</a>
            <a href="https://www.idahostatesman.com/myaccount">Vacation Hold</a>
            <a href="https://www.idahostatesman.com/myaccount">Pay Your Bill</a>
            </div>
    <div class="package">
            <h6 class="h5 caps">Learn More</h6>
            <a href="https://www.mcclatchy.com/our-impact/markets/idaho-statesman/#navlink=mi_footer">About Us</a>
            <a href="https://www.idahostatesman.com/customer-service/contact-us/#navlink=mi_footer">Contact Us</a>
            <a href="http://t.news.idahostatesman.com/webApp/mccSignupPage?siteName=idahostatesman#navlink=mi_footer">Newsletters</a>
            <a href="https://k12nie.com/?p=idahostatesman#navlink=mi_footer">News in Education</a>
            <a href="https://www.idahostatesman.com/archives/#navlink=mi_footer">Archives</a>
            </div>
    <div class="package">
            <h6 class="h5 caps">Advertising</h6>
            <a href="https://www.idahostatesman.com/classifieds/#navlink=mi_footer">Place a Classified</a>
            </div>
    </div>
  </section>
</footer>

<section class="bottom-nav h5">
    <a class="legal-links-item caps" href="https://www.idahostatesman.com/customer-service/copyright/#navlinks=footer">Copyright</a>
        <a class="legal-links-item caps" href="https://www.idahostatesman.com/customer-service/privacy-policy/#navlink=mi_footer">Privacy Policy</a>
        <a id="onetrust-donotsell" class="ot-sdk-show-settings legal-links-item caps">Do Not Sell My Personal Information</a>
            <a class="legal-links-item caps" href="https://www.idahostatesman.com/customer-service/terms-of-service/#navlink=mi_footer">Terms of Service</a>
        </section>

  
        
        
    <div id="mistatstag" style="display:none;">
        
            <script src="//media.idahostatesman.com/mistats/products/escenic_s_code.js"></script>
            <script src="//media.idahostatesman.com/mistats/products/escenic.js"></script>
            <script src="//media.idahostatesman.com/mistats/finalizestats.js"></script>
        
    </div>


        
    
         












    




    

        
        
    
    
    
    
    
    
    <script type="text/javascript">
        document.addEventListener('DOMContentLoaded', function() {
            UD.updateDate.functionsUpdateDate.validateMomentScript("MMMM DD, YYYY hh:mm A", "en", "-07:00");
        });
    </script>
<script type="text/javascript">
    var WFClientTypeDef = {
        "extraSmall": "(max-width: 767px)",
        "medium": "(min-width: 992px) and (max-width: 1199px)",
        "large": "(min-width: 1200px)",
        "small": "(min-width: 768px) and (max-width: 991px)"
    };
    var imageSizes = [80, 160, 200, 320, 400, 480, 560, 640, 720, 768, 960, 1080, 1140];
</script>
<script type="text/javascript" src="/wps/build/webpack/mi-footer.bundle-42b17184389873244a71.js"></script>

<script src="//imasdk.googleapis.com/js/sdkloader/ima3.js" type="text/javascript"></script>

<script src="https://ovp.iris.tv/libs/adaptive/v2/iris.adaptive.js" type="text/javascript"></script>
    <script src="https://ovp.iris.tv/libs/context/iris-context.min.js" type="text/javascript"></script>
    <script type="text/javascript" src="/wps/build/webpack/vue.bundle-3ab3918677131d13ac6b.js"></script>
    <script type="text/javascript" src="/wps/build/webpack/videojs.bundle-890a2e28dc5356b380ad.js"></script>
    <script type="text/javascript" src="/wps/build/webpack/videoStory.bundle-bea9baa9692570d9a138.js"></script>
    <script type="text/javascript" src="/wps/build/webpack/galleryStoryPage.bundle-c2bfb57c23db0d1863e3.js"></script>



    
        <script type="text/javascript" src="/wps/build/webpack/footer.bundle-48e1abb1baf89b0424e3.js"></script>
    

        
    </body>
</html>
